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Unit-1: Internet Fundamentals 
Short Answer QuesƟons: 
 
Q. What are bookmarks? Give example. (Nov 19) 
Ans. Bookmarks are saved links to specific web pages for quick access. 
Example: Saving "www.google.com" in Chrome bookmarks for instant search. 
Bookmarks ਉਹ ਸੰਭਾਲੀ ਹਈੋਆ ਂ ਿਲੰਕ� ਹੁੰ ਦੀਆ ਂਹਨ ਜੋ ਖਾਸ ਵੈ{ਬ ਪੇਜ� ਤੱਕ ਤੇਜ਼ ਪਹੁੰ ਚ ਲਈ ਵਰਤੀ ਜ�ਦੀਆ ਂਹਨ। 

ਉਦਾਹਰਨ: Chrome ਿਵੱਚ "www.google.com" ਨੰੂ ਬੁੱ ਕਮਾਰਕ ਕਰਨਾ ਤ� ਜੋ ਤੁਰੰਤ ਸચӪ ਕੀਤਾ ਜਾ ਸਕ।ੇ  

 
Q. What do you mean by Internet? What are its uses? (Nov 19) 
Ans. Internet and its uses: The Internet is a global network that connects millions of computers. 
It is used for communicaƟon, browsing, entertainment, educaƟon, and online services. 
ਇੰਟਰਨă {ਟ ਅਤੇ ਇਸਦ ੇਉਪਯਗੋ: ਇੰਟਰਨă {ਟ ਇੱਕ ਗਲੋਬਲ ਨă {ਟਵਰਕ ਹ ੈਜੋ ਲੱਖ� ਕੰਿਪਊਟਰ� ਨੰੂ ਆਪਸ ਿਵੱਚ ਜੋੜਦਾ ਹ।ੈ 

ਇਸਦਾ ਉਪਯੋਗ ਸੰਚਾਰ, ਬਰਾਊਿਜ਼ੰਗ, ਮਨĄ ਰੰਜਨ, ਿਸੱਿਖਆ ਅਤ ੇਆਨਲਾਈਨ ਸੇਵਾਵ� ਲਈ ਕੀਤਾ ਜ�ਦਾ ਹ।ੈ 
 
Q. Telnet (Nov 23) 
Ans. Telnet: Telnet is a network protocol used to access remote computers over a TCP/IP network. 
It allows users to log in and execute commands remotely. 
ਟੈਲਨă {ਟ: ਟਲੈਨă {ਟ ਇੱਕ ਨă {ਟਵਰਕ ਪਰਟੋੋਕਲੋ ਹ ੈ ਜੋ TCP/IP ਨă {ਟਵਰਕ ਰਾਹ� ਦੂਰਲੇ ਕੰਿਪਊਟਰ� ਤੱਕ ਪਹੁੰ ਚ ਕਰਨ ਲਈ 

ਵਰਿਤਆ ਜ�ਦਾ ਹ।ੈ ਇਹ ਉਪਭਗੋਿਤਆ ਂਨੰੂ ਦੂਰਲੇ ਕੰਿਪਊਟਰ 'ਚ ਲਾਗਇਨ ਕਰਨ ਅਤ ੇਕਮ�ਡ� ਚਲਾਉਣ ਦੀ ਆਿਗਆ ਿਦੰਦਾ 

ਹ।ੈ 

 
Q. HTTP (Nov 23) 
Ans.   HTTP (HyperText Transfer Protocol): HTTP is the protocol used for transferring web pages over 
the internet. It defines how messages are formaƩed and transmiƩed between clients and servers. 
HTTP (ਹਾਈਪਰਟੈਕਸਟ ਟ��ਸਫਰ ਪਰੋਟੋਕੋਲ): HTTP ਇੰਟਰਨă {ਟ 'ਤੇ ਵ{ੈਬ ਪੰਿਨਆਂ ਦੇ ਆਦਾਨ-ਪ�ਦਾਨ ਲਈ ਵਰਿਤਆ ਜ�ਦਾ 

ਪਰਟੋੋਕਲੋ ਹ।ੈ ਇਹ ਇਹ ਿਨਰਧਾਰਤ ਕਰਦਾ ਹ ੈਿਕ ਿਕਵ� ਸੁਨĂ ਹ ੇ(messages) ਨੰੂ ਿਤਆਰ ਕੀਤਾ ਜ�ਦਾ ਹ ੈਅਤ ੇਕਲਾਇੰਟ ਅਤ ੇ

ਸਰਵਰ ਦਰਿਮਆਨ ਭੇਿਜਆ ਜ�ਦਾ ਹ।ੈ 

 
Q. Define TCP/IP. (Nov 24) 
Ans. TCP/IP is the foundaƟonal communicaƟon protocol for the Internet. 
It ensures reliable data transfer between computers over networks. 
TCP/IP ਇੰਟਰਨă {ਟ ਲਈ ਬਿੁਨਆਦੀ ਸੰਚਾਰ ਪਰਟੋੋਕੋਲ ਹ।ੈ ਇਹ ਨă {ਟਵਰਕ� ਰਾਹ� ਕੰਿਪਊਟਰ� ਿਵਚਕਾਰ ਡਾਟਾ ਦੀ ਭਰੋਸਯੇੋਗ 

ਟ��ਸਫਰ ਨੰੂ ਯਕੀਨੀ ਬਣਾ�ਦਾ ਹ।ੈ 

 
Q. Discuss the use of telnet. (Nov 24) 
Ans. Telnet is used to remotely control devices or servers over a network. 
It's commonly used by network administrators for configuraƟon and troubleshooƟng. 
ਟੈਲਨă ਟ ਨă {ਟਵਰਕ ਰਾਹ� ਿਡਵਾਈਸ� ਜ� ਸਰਵਰ� ਨੰੂ ਦੂਰ� ਕੰਟਰਲੋ ਕਰਨ ਲਈ ਵਰਿਤਆ ਜ�ਦਾ ਹ।ੈ 

ਇਹ ਆਮ ਤੌਰ 'ਤ ੇ ਨă {ਟਵਰਕ ਐਡਿਮਿਨਸਟ�ਟੇਰ� ਵੱਲ� ਸੰਰਚਨਾ (configuraƟon) ਅਤ ੇ ਸਮੱਿਸਆ ਹੱਲ ਕਰਨ 

(troubleshooƟng) ਲਈ ਵਰਿਤਆ ਜ�ਦਾ ਹ।ੈ 
 
Q. Why FTP is used? (Nov 24) 
Ans. FTP is used to transfer files between a client and a server on a network. 
It allows uploading, downloading, and managing files on remote systems. 
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ਐਫ਼ਟੀਪੀ (FTP) ਇੱਕ ਕਲਾਇੰਟ ਅਤ ੇਸਰਵਰ ਦ ੇਦਰਿਮਆਨ ਨă {ਟਵਰਕ 'ਤ ੇਫਾਈਲ� ਤਬਦੀਲ ਕਰਨ ਲਈ ਵਰਿਤਆ 

ਜ�ਦਾ ਹੈ। ਇਹ ਦੂਰਲੇ ਿਸਸਟਮ� 'ਤ ੇਫਾਈਲ� ਨੰੂ ਅੱਪਲੋਡ, ਡਾਊਨਲੋਡ ਅਤ ੇਪ�ਬੰਿਧਤ ਕਰਨ ਦੀ ਆਿਗਆ ਿਦੰਦਾ ਹੈ। 
 
Long Answer QuesƟons: 
Q. What are the components of Internet? Explain its working in detail. (Nov 23) 
Ans. The Internet is a global network that connects millions of computers and devices worldwide. It 
funcƟons through various components that work together to provide seamless communicaƟon and 
access to data. 
Main components of the Internet: 

1. Web Servers: Store and deliver websites, files, and data to users. 
2. Clients (Browsers): Devices like computers or smartphones that request data from servers using 

web browsers. 
3. IP Addresses & DNS: Every device has a unique IP address. DNS (Domain Name System) 

translates website names into IP addresses. 
4. Routers & Switches: Direct data packets across networks and maintain traffic flow. 
5. ISPs (Internet Service Providers): Companies that provide users with Internet access. 
6. Protocols: Rules like TCP/IP, HTTP, and FTP that define how data is transferred over the Internet. 

Working of the Internet: When a user types a URL (like www.google.com) into a browser, the request 
goes to the DNS server to find the correct IP address. The request is then routed through the ISP and 
switches/routers to the web server. The server sends back the requested web page in data packets, 
which are reassembled by the client’s browser. 
This enƟre process happens in milliseconds, enabling fast access to informaƟon globally. 
ਇੰਟਰਨă {ਟ ਇੱਕ ਗਲੋਬਲ ਨă {ਟਵਰਕ ਹੈ ਜ ੋਦੁਨੀਆਂ ਭਰ ਿਵੱਚ ਲੱਖ� ਕੰਿਪਊਟਰ� ਅਤ ੇਿਡਵਾਈਸ� ਨੰੂ ਜੋੜਦਾ ਹੈ। ਇਹ ਵੱਖ-

ਵੱਖ ਿਹੱਿਸਆਂ ਰਾਹ� ਕੰਮ ਕਰਦਾ ਹੈ ਜ ੋਇੱਕੱਠĂ  ਹੋ ਕ ੇਸੰਜੋਗਯੋਗ ਸੰਚਾਰ ਅਤ ੇਡਾਟਾ ਤੱਕ ਪਹੰੁਚ ਯਕੀਨੀ ਬਣਾ�ਦ ੇਹਨ। 
ਇੰਟਰਨă {ਟ ਦ ੇਮੱੁਖ ਿਹੱਸੇ: 

1. ਵ{ੈਬ ਸਰਵਰ: ਵੈ{ਬਸਾਈਟ�, ਫਾਈਲ� ਅਤ ੇਡਾਟਾ ਨੰੂ ਸੰਭਾਲਦ ੇਅਤ ੇਯੂਜ਼ਰ� ਨੰੂ ਭੇਜਦ ੇਹਨ। 
2. ਕਲਾਇੰਟ (ਬਰਾਊਜ਼ਰ): ਕੰਿਪਊਟਰ ਜ� ਸਮਾਰਟਫੋਨ ਵਰਗੀਆਂ ਿਡਵਾਈਸ� ਜੋ ਵੈ{ਬ ਸਰਵਰ ਤ� ਡਾਟਾ ਦੀ ਮੰਗ 

ਕਰਦੀਆ ਂਹਨ। 

3. IP ਐਡਰੈ{ਸ ਅਤ ੇ DNS: ਹਰ ਿਡਵਾਈਸ ਦਾ ਇੱਕ ਿਵਲੱਖਣ IP ਐਡਰ{ੈਸ ਹੁੰ ਦਾ ਹ।ੈ DNS (ਡੋਮਨੇ ਨ� ਿਸਸਟਮ) 

ਵੈ{ਬਸਾਈਟ ਨ� ਨੰੂ IP ਐਡਰ{ੈਸ ਿਵੱਚ ਤਬਦੀਲ ਕਰਦਾ ਹ।ੈ 
4. ਰਾਊਟਰ ਅਤ ੇਸਿਵੱਚ: ਨă {ਟਵਰਕ ਰਾਹ� ਡਾਟਾ ਪੈਕਟ� ਨੰੂ ਸਹੀ ਿਦ©ਾ ਿਵੱਚ ਭੇਜਦ ੇਹਨ ਅਤ ੇਟ�ੈਿਫਕ ਦਾ ਪ�ਬੰਧ ਕਰਦੇ 

ਹਨ। 

5. ISP (ਇੰਟਰਨă {ਟ ਸੇਵਾ ਪ�ਦਾਤਾ): ਉਹ ਕੰਪਨੀਆ ਂਜੋ ਉਪਭੋਗਤਾਵ� ਨੰੂ ਇੰਟਰਨă {ਟ ਸੇਵਾ ਿਦੰਦੀਆ ਂਹਨ। 

6. ਪ�ੋਟੋਕੋਲ (ਿਨਯਮ): TCP/IP, HTTP, ਅਤ ੇ FTP ਵਰਗੇ ਿਨਯਮ ਜੋ ਇੰਟਰਨă {ਟ ਰਾਹ� ਡਾਟਾ ਤਬਾਦਲੇ ਦਾ ਤਰੀਕਾ 

ਿਨਰਧਾਰਤ ਕਰਦ ੇਹਨ। 
ਇੰਟਰਨă {ਟ ਦਾ ਕੰਮ ਕਰਨ ਦਾ ਤਰੀਕਾ: ਜਦ� ਕੋਈ ਯੂਜ਼ਰ ਆਪਣੇ ਬਰਾਊਜ਼ਰ ਿਵੱਚ ਿਕਸ ੇURL (ਿਜਵ� www.google.com) ਨੰੂ 

ਿਲਖਦਾ ਹ,ੈ ਤ� ਇਹ ਬਨੇਤੀ DNS ਸਰਵਰ ਕਲੋ ਜ�ਦੀ ਹ ੈਜੋ ਸਹੀ IP ਐਡਰ{ੈਸ ਖੋਜਦਾ ਹ।ੈ ਇਹ ਬੇਨਤੀ ISP ਅਤ ੇਰਾਊਟਰ� ਰਾਹ� 

ਵੈ{ਬ ਸਰਵਰ ਤੱਕ ਭੇਜੀ ਜ�ਦੀ ਹ।ੈ ਿਫਰ ਸਰਵਰ ਵੱਲ� ਵੈ{ਬਪੇਜ ਡਾਟਾ ਪੈਕਟ� ਦੇ ਰੂਪ ਿਵੱਚ ਭੇਿਜਆ ਜ�ਦਾ ਹ,ੈ ਜੋ ਿਕ ਯੂਜ਼ਰ ਦ ੇ

ਬਰਾਊਜ਼ਰ ਵੱਲ� ਮੁੜ ਜੋਿੜਆ ਜ�ਦਾ ਹ।ੈ ਇਹ ਪੂਰਾ ਪ�ਿਕਿਰਆ ਿਸਰਫ ਕੁਝ ਿਮ.ਸ.ੈ ਿਵੱਚ ਪੂਰਾ ਹ ੋਜ�ਦਾ ਹ,ੈ ਜੋ ਦੁਨੀਆ ਂਭਰ ਿਵੱਚ 

ਤੇਜ਼ ਅਤ ੇਲਗਾਤਾਰ ਜਾਣਕਾਰੀ ਤੱਕ ਪਹੁੰ ਚ ਸੰਭਵ ਬਣਾ�ਦਾ ਹ।ੈ 
 
Q. What is the use of Internet in Business? (Nov 24) 
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Ans. The Internet plays a crucial role in modern business by enhancing communicaƟon, increasing 
efficiency, and expanding market reach. It allows businesses to operate globally, connect with 
customers, and manage operaƟons with ease. 
One of the primary uses of the Internet in business is communicaƟon. Emails, video conferencing, and 
instant messaging help employees, partners, and customers stay connected in real-Ɵme, reducing the 
need for physical meeƟngs. Digital markeƟng through websites, social media, and email campaigns 
helps businesses reach a wider audience at lower costs. 
E-commerce is another major use, allowing companies to sell products and services online 24/7. This 
not only increases sales but also provides customers with convenience. Businesses use cloud compuƟng 
for data storage, remote access, and collaboraƟon, reducing infrastructure costs. 
The Internet also aids in market research, compeƟtor analysis, and customer feedback collecƟon. It 
streamlines internal operaƟons through tools like online accounƟng, inventory management, and HR 
systems. AddiƟonally, online banking and financial transacƟons ensure smooth business operaƟons. 
In summary, the Internet has transformed tradiƟonal business models by enabling faster 
communicaƟon, global expansion, beƩer customer engagement, and cost-effecƟve operaƟons, making 
it an essenƟal tool in today’s compeƟƟve world. 
ਇੰਟਰਨă {ਟ ਆਧਿੁਨਕ ਵਪਾਰ ਿਵੱਚ ਇਕ ਅਹੰਕਾਰਪੂਰਨ ਭੂਿਮਕਾ ਿਨਭ�ਦਾ ਹੈ ਿਕ�ਿਕ ਇਹ ਸੰਚਾਰ ਨੰੂ ਵਧਾ�ਦਾ ਹੈ, 

ਦਫ਼ਤਰੀ ਕਾਰਜਕ©ੁਲਤਾ ਨੰੂ ਤਜ਼ੇ ਕਰਦਾ ਹੈ ਅਤ ੇਮਾਰਕੀਟ ਪਹੁੰ ਚ ਨੰੂ ਿਵਸਥਾਰ ਿਦੰਦਾ ਹੈ। ਇਹ ਕਾਰੋਬਾਰ� ਨੰੂ ਗਲੋਬਲ 

ਪੱਧਰ 'ਤ ੇਕੰਮ ਕਰਨ, ਗਾਹਕ� ਨਾਲ ਜੁੜਨ ਅਤ ੇਆਪਣ ੇਓਪਰੇ©ਨ� ਨੰੂ ਆਸਾਨੀ ਨਾਲ ਸੰਭਾਲਣ ਿਵੱਚ ਸਹਾਇਤਾ ਕਰਦਾ 

ਹੈ। ਵਪਾਰ ਿਵੱਚ ਇੰਟਰਨă {ਟ ਦੀ ਮੁੱ ਖ ਵਰਤ� ਸੰਚਾਰ ਲਈ ਕੀਤੀ ਜ�ਦੀ ਹ।ੈ ਈਮੇਲ, ਵੀਡੀਓ ਕਾਨਫਰੰਿਸੰਗ ਅਤ ੇਇੰਸਟ�ਟ ਮੈਸੇਿਜੰਗ 

ਵਰਗੇ ਔਜਾਰ ਕਰਮਚਾਰੀਆ,ਂ ਸਾਥੀਆ ਂਅਤ ੇਗਾਹਕ� ਨੰੂ ਤੁਰੰਤ ਜੁੜ ੇਰੱਖਦੇ ਹਨ, ਿਜਸ ਨਾਲ ਭੌਿਤਕ ਮੀਿਟੰਗ� ਦੀ ਲੋੜ ਘੱਟ ਜ�ਦੀ 

ਹ।ੈ ਵੈ{ਬਸਾਈਟ�, ਸ©ੋਲ ਮੀਡੀਆ ਅਤ ੇਈਮੇਲ ਕ�ਪਨੇ� ਰਾਹ� ਿਡਜੀਟਲ ਮਾਰਕੀਿਟੰਗ ਕਾਰਬੋਾਰ� ਨੰੂ ਘੱਟ ਖਰਚ ੇ'ਤੇ ਵੱਡੀ ਦਰ©ਕ 

ਸੰਿਖਆ ਤੱਕ ਪਹੁੰ ਚਾ�ਦੀ ਹ।ੈ ਈ-ਕਾਮਰਸ ਇੱਕ ਹੋਰ ਮਹੱਤਵਪੂਰਨ ਖੇਤਰ ਹ,ੈ ਜੋ ਕੰਪਨੀਆ ਂਨੰੂ ਆਪਣੇ ਉਤਪਾਦ ਅਤ ੇਸਵੇਾਵ� 

24/7 ਆਨਲਾਈਨ ਵਚੇਣ ਦੀ ਸਹੂਲਤ ਿਦੰਦਾ ਹ।ੈ ਇਹ ਨਾ ਿਸਰਫ ਿਵਕਰੀ ਵਧਾ�ਦਾ ਹ,ੈ ਸਗ� ਗਾਹਕ� ਲਈ ਆਸਾਨੀ ਵੀ ਪਦੈਾ 

ਕਰਦਾ ਹ।ੈ ਕਲਾਊਡ ਕੰਿਪਊਿਟੰਗ ਰਾਹ� ਡਾਟਾ ਸਟੋਰਜੇ, ਿਰਮਟੋ ਐਕਸ{ੈਸ ਅਤ ੇਸ�ਝੇਦਾਰੀ ਆਸਾਨ ਹ ੋਜ�ਦੀ ਹ,ੈ ਿਜਸ ਨਾਲ 

ਢ�ਚਾਗਤ ਖਰਚ ੇਘੱਟ ਹੁੰ ਦ ੇਹਨ। ਇੰਟਰਨă {ਟ ਮਾਰਕੀਟ ਿਰਸਰਚ, ਮਕੁਾਬਲੇਦਾਰ� ਦੀ ਿਵ©ਲੇ©ਣ ਅਤ ੇਗਾਹਕ ਫੀਡਬੈਕ ਇਕੱਤਰ 

ਕਰਨ ਿਵੱਚ ਵੀ ਸਹਾਇਤਾ ਕਰਦਾ ਹ।ੈ ਅੰਦਰੂਨੀ ਓਪਰੇ©ਨ� ਨੰੂ ਆਨਲਾਈਨ ਅਕਾ�ਿਟੰਗ, ਸਟਕੌ ਮੈਨĂ ਜਮ�ਟ ਅਤ ੇHR ਿਸਸਟਮ� 

ਰਾਹ� ਆਸਾਨੀ ਨਾਲ ਸੰਚਾਲਤ ਕੀਤਾ ਜ�ਦਾ ਹ।ੈ ਇਸਦ ੇਇਲਾਵਾ, ਆਨਲਾਈਨ ਬ�ਿਕੰਗ ਅਤ ੇ ਿਵੱਤੀ ਲੈਣ-ਦਣੇ ਕਾਰੋਬਾਰ ਦੀ 

ਲਗਾਤਾਰਤਾ ਯਕੀਨੀ ਬਣਾ�ਦੇ ਹਨ। ਸਾਰ ਤੌਰ 'ਤ,ੇ ਇੰਟਰਨă {ਟ ਨĂ  ਰਵਾਇਤੀ ਵਪਾਰ ਮਾਡਲ� ਨੰੂ ਬਦਲ ਿਦੱਤਾ ਹ ੈ— ਤੇਜ਼ 

ਸੰਚਾਰ, ਗਲੋਬਲ ਵਾਧਾ, ਗਾਹਕ� ਨਾਲ ਿਬਹਤਰ ਸੰਪਰਕ ਅਤ ੇਘੱਟ ਖਰਚ ਵਾਲੀਆ ਂਓਪਰੇ©ਨ� ਰਾਹ� — ਿਜਸ ਕਾਰਨ ਇਹ 

ਆਧਿੁਨਕ ਮੁਕਾਬਲੇਦਾਰ ਦੁਨੀਆ ਂਿਵੱਚ ਇੱਕ ਅਣਮੁੱਲਾ ਔਜਾਰ ਬਣ ਿਗਆ ਹ।ੈ 
 
Q. How Web browsing is used in opening and viewing the Web Pages? (Nov 24) 
Ans. Web browsing is the process of accessing and viewing informaƟon available on the Internet using 
a soŌware applicaƟon called a web browser (e.g., Google Chrome, Mozilla Firefox, MicrosoŌ Edge). It 
allows users to navigate websites, view content, and interact with mulƟmedia and online tools. 
When a user enters a website address (URL) in the browser's address bar, the browser sends a request 
to a Domain Name System (DNS) to convert the human-readable website name into an IP address. This 
IP address helps locate the web server hosƟng the requested content. 
Once the browser connects to the server, it uses the HTTP or HTTPS protocol to request the specific 
web page. The server responds by sending the page's data (HTML, CSS, images, etc.) in the form of data 
packets to the browser. 
The browser then interprets the code and displays the web page in a readable and interacƟve format. 
Users can scroll, click links, fill forms, watch videos, or download files during browsing. 
In short, web browsing is a user-friendly way to access and explore content on the Internet, enabling 
users to retrieve vast informaƟon efficiently from anywhere in the world. 
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ਵ{ੈਬ ਬਰਾਊਿਜ਼ੰਗ (Web Browsing) ਉਹ ਪ�ਿਕਿਰਆ ਹ ੈ ਿਜਸ ਿਵੱਚ ਇੱਕ ਯੂਜ਼ਰ ਇੰਟਰਨă {ਟ �ਤ ੇਉਪਲਬਧ ਜਾਣਕਾਰੀ ਨੰੂ 

ਵੇਖਣ ਅਤ ੇਪ�ਾਪਤ ਕਰਨ ਲਈ ਇੱਕ ਸੋਫਟਵੇਅਰ ਐਪਲੀਕ©ੇਨ — ਿਜਸਨੰੂ ਵੈ{ਬ ਬਰਾਊਜ਼ਰ ਿਕਹਾ ਜ�ਦਾ ਹ ੈ(ਿਜਵ� ਿਕ Google 

Chrome, Mozilla Firefox, ਜ� MicrosoŌ Edge) — ਦੀ ਵਰਤ� ਕਰਦਾ ਹ।ੈ ਇਹ ਯੂਜ਼ਰ ਨੰੂ ਵੈ{ਬਸਾਈਟ� �ਤ ੇਨĂ ਵੀਗੇਟ 

ਕਰਨ, ਸਮੱਗਰੀ ਦੇਖਣ ਅਤ ੇਮਲਟੀਮੀਡੀਆ ਜ� ਆਨਲਾਈਨ ਟੂਲਜ਼ ਨਾਲ ਇੰਟਰਐਕਟ ਕਰਨ ਦੀ ਆਿਗਆ ਿਦੰਦਾ ਹ।ੈ 
ਜਦ� ਇੱਕ ਯੂਜ਼ਰ ਬਰਾਊਜ਼ਰ ਦੀ ਐਡਰ{ੈਸ ਬਾਰ ਿਵੱਚ ਿਕਸ ੇਵੈ{ਬਸਾਈਟ ਦਾ URL ਦਰਜ ਕਰਦਾ ਹ,ੈ ਤ� ਬਰਾਊਜ਼ਰ ਉਹ ਿਨਰਦ©ੇ 

DNS (Domain Name System) ਨੰੂ ਭੇਜਦਾ ਹ।ੈ DNS ਇਸ ਮਨੱੁਖੀ ਪਾਠਯੋਗ URL ਨੰੂ IP ਐਡਰ{ੈਸ ਿਵੱਚ ਤਬਦੀਲ ਕਰਦਾ ਹ,ੈ 

ਜੋ ਿਕ ਉਸ ਸਰਵਰ ਨੰੂ ਲੱਭਣ ਿਵੱਚ ਮਦਦ ਕਰਦਾ ਹ ੈਿਜੱਥ ੇਉਕਤ ਸਮੱਗਰੀ ਹੋਸਟ ਕੀਤੀ ਗਈ ਹੁੰ ਦੀ ਹ।ੈ 

ਇਸ ਤ� ਬਾਅਦ, ਬਰਾਊਜ਼ਰ HTTP ਜ� HTTPS ਪ�ੋਟਕੋੋਲ ਰਾਹ� ਵੈ{ਬਸਾਈਟ ਦੀ ਮੰਗ ਕਰਦਾ ਹ।ੈ ਸਰਵਰ HTML, CSS, ਿਚੱਤਰ 

ਆਿਦ ਦੇ ਰੂਪ ਿਵੱਚ ਡਟੇਾ ਪੈਕਟੇ ਭਜੇ ਕ ੇਜਵਾਬ ਿਦੰਦਾ ਹ।ੈ 

ਬਰਾਊਜ਼ਰ ਇਸ ਕਡੋ ਨੰੂ ਪੜ�ਦਾ ਹ ੈਅਤ ੇਇੱਕ ਪਾਠਯੋਗ ਅਤ ੇਇੰਟਰਐਕਿਟਵ ਫਾਰਮਟੈ ਿਵੱਚ ਪੇਜ਼ ਿਦਖਾ�ਦਾ ਹ।ੈ ਵੈ{ਬ ਬਰਾਊਿਜ਼ੰਗ 

ਦੌਰਾਨ, ਯੂਜ਼ਰ ਸਕ�ਲੋ ਕਰ ਸਕਦੇ ਹਨ, ਿਲੰਕ 'ਤੇ ਕਿਲੱਕ ਕਰ ਸਕਦੇ ਹਨ, ਫਾਰਮ ਭਰ ਸਕਦ ੇਹਨ, ਵੀਡੀਓ ਦੇਖ ਸਕਦ ੇਹਨ ਜ� 

ਫਾਈਲ� ਡਾਊਨਲੋਡ ਕਰ ਸਕਦ ੇਹਨ। 

ਸੰਖੇਪ ਿਵੱਚ, ਵੈ{ਬ ਬਰਾਊਿਜ਼ੰਗ ਇੰਟਰਨă {ਟ �ਤੇ ਜਾਣਕਾਰੀ ਤੱਕ ਪਹੁੰ ਚ ਕਰਨ ਅਤ ੇਪੜ�ਨ ਦਾ ਇੱਕ ਆਸਾਨ ਤੇ ਪ�ਭਾਵ©ਾਲੀ ਢੰਗ 

ਹ,ੈ ਜੋ ਦਨੁੀਆ ਭਰ 'ਚ ਿਕਤ ੇਵੀ ਬਠੈ ਕ ੇਅਣਿਗਣਤ ਜਾਣਕਾਰੀ ਤੱਕ ਪਹੁੰ ਚ ਯਕੀਨੀ ਬਣਾ�ਦਾ ਹ।ੈ 

 
Q. Explain various internet protocols. (Nov 19) 
Ans. Internet protocols are a set of rules that govern how data is transmiƩed over the Internet. They 
ensure proper communicaƟon between devices across networks. Here are some of the most commonly 
used Internet protocols: 

1. TCP/IP (Transmission Control Protocol/Internet Protocol): It is the foundaƟonal protocol of the 
Internet. IP handles addressing and rouƟng of packets, while TCP ensures reliable delivery by 
checking for errors and ensuring all data packets arrive correctly. 

2. HTTP (HyperText Transfer Protocol): This protocol is used for accessing web pages on the 
Internet. It defines how messages are formaƩed and transmiƩed between web servers and 
browsers. HTTPS (secure version) encrypts the data for security. 

3. FTP (File Transfer Protocol): Used to transfer files between a client and a server. FTP allows 
uploading, downloading, renaming, and deleƟng files on a remote server. 

4. SMTP (Simple Mail Transfer Protocol): Used for sending emails from a client to a server or 
between servers. 

5. IMAP/POP3: These are used to receive emails. IMAP allows accessing email from mulƟple 
devices, while POP3 downloads it to one device. 

6. DNS (Domain Name System): Translates domain names (like www.google.com) into IP 
addresses, allowing browsers to locate websites. 

These protocols work together to provide smooth and secure Internet communicaƟon. 
ਇੰਟਰਨă {ਟ ਪ�ਟੋੋਕੋਲ (Internet Protocols) ਉਹ ਿਨਯਮ� ਦੀ ਇਕ ਲੜੀ ਹ ੈਜੋ ਇੰਟਰਨă {ਟ ਰਾਹ� ਡਾਟਾ ਦੇ ਟ��ਸਿਮ©ਨ ਨੰੂ ਸਚੁਾਰ ੂ

ਬਣਾ�ਦੀ ਹ।ੈ ਇਹ ਿਨਯਮ ਇਹ ਯਕੀਨੀ ਬਣਾ�ਦ ੇਹਨ ਿਕ ਵੱਖ-ਵੱਖ ਿਡਵਾਈਸ� ਿਵਚਕਾਰ ਸਹੀ ਢੰਗ ਨਾਲ ਸੰਚਾਰ ਹੋਵੇ। ਹੇਠ� 

ਕੁਝ ਸਭ ਤ� ਿਜਆਦਾ ਵਰਤ ੇਜ�ਦੇ ਇੰਟਰਨă {ਟ ਪ�ੋਟਕੋੋਲ ਿਦੱਤ ੇਗਏ ਹਨ: 

 
1. TCP/IP (Transmission Control Protocol / Internet Protocol): ਇਹ ਇੰਟਰਨă {ਟ ਦਾ ਮਲੂ ਪ�ੋਟੋਕੋਲ ਹ।ੈ IP ਪੈਕੇਟ� ਦੀ 

ਐਡਰੈਿਸੰਗ ਅਤ ੇਰਾਊਿਟੰਗ ਦਾ ਕੰਮ ਕਰਦਾ ਹ,ੈ ਜਦਿਕ TCP ਇਹ ਯਕੀਨੀ ਬਣਾ�ਦਾ ਹ ੈਿਕ ਸਾਰ ੇਡਾਟਾ ਪੈਕੇਟ ਗਲਤੀ ਤ� ਰਿਹਤ 

ਅਤ ੇਸਹੀ ਢੰਗ ਨਾਲ ਪਹੁੰ ਚਣ। 
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2. HTTP (HyperText Transfer Protocol): ਇਹ ਪ�ੋਟੋਕਲੋ ਇੰਟਰਨă {ਟ �ਤੇ ਵੈ{ਬ ਪੇਜ� ਤੱਕ ਪਹੁੰ ਚ ਕਰਨ ਲਈ ਵਰਿਤਆ 

ਜ�ਦਾ ਹ।ੈ ਇਹ ਵੈ{ਬ ਸਰਵਰ ਅਤ ੇਬਰਾਊਜ਼ਰ ਿਵਚਕਾਰ ਸੁਨĂ ਿਹਆ ਂਨੰੂ ਭੇਜਣ ਅਤ ੇਪ�ਾਪਤ ਕਰਨ ਦੇ ਿਨਯਮ ਦੱਸਦਾ ਹ।ੈ HTTPS 

ਇਸ ਦਾ ਸੁਰੱਿਖਅਤ ਰੂਪ ਹ,ੈ ਜੋ ਡਾਟਾ ਨੰੂ ਐਨਿਕ�ਪਟ ਕਰਦਾ ਹ।ੈ 
3. FTP (File Transfer Protocol): ਇਹ ਕਲਾਇੰਟ ਅਤ ੇਸਰਵਰ ਿਵਚਕਾਰ ਫਾਈਲ� ਭੇਜਣ ਜ� ਪ�ਾਪਤ ਕਰਨ ਲਈ ਵਰਿਤਆ 

ਜ�ਦਾ ਹ।ੈ ਇਸ ਰਾਹ� ਫਾਈਲ� ਅੱਪਲੋਡ, ਡਾਊਨਲੋਡ, ਨ� ਬਦਲਣ ਜ� ਿਮਟਾਉਣੀਆਂ ਵੀ ਜਾ ਸਕਦੀਆ ਂਹਨ। 
4. SMTP (Simple Mail Transfer Protocol): ਇਹ ਪ�ੋਟੋਕਲੋ ਈਮੇਲ ਭੇਜਣ ਲਈ ਵਰਿਤਆ ਜ�ਦਾ ਹ ੈ— ਜ� ਤ� ਕਲਾਇੰਟ ਤ� 

ਸਰਵਰ ਤੱਕ ਜ� ਇੱਕ ਸਰਵਰ ਤ� ਦੂਜ ੇਤੱਕ। 

5. IMAP / POP3: ਇਹ ਈਮੇਲ ਪ�ਾਪਤ ਕਰਨ ਲਈ ਵਰਤ ੇਜ�ਦੇ ਹਨ। IMAP ਇੱਕ ਹੀ ਈਮੇਲ ਨੰੂ ਕਈ ਿਡਵਾਈਸ� �ਤੇ ਪੜ�ਨ 

ਦੀ ਆਿਗਆ ਿਦੰਦਾ ਹ,ੈ ਜਦਿਕ POP3 ਈਮੇਲ ਨੰੂ ਇਕ ਹੀ ਿਡਵਾਈਸ 'ਤੇ ਡਾਊਨਲੋਡ ਕਰ ਲ�ਦਾ ਹ।ੈ 

6. DNS (Domain Name System): ਇਹ ਡੋਮਨੇ ਨ� (ਿਜਵ� www.google.com) ਨੰੂ IP ਐਡਰ{ੈਸ ਿਵੱਚ ਤਬਦੀਲ ਕਰਦਾ ਹ,ੈ 

ਿਜਸ ਨਾਲ ਬਰਾਊਜ਼ਰ ਵ{ੈਬਸਾਈਟ ਨੰੂ ਲੱਭ ਸਕਦਾ ਹ।ੈ 

ਸੰਖੇਪ ਿਵੱਚ, ਇਹ ਸਾਰ ੇਪ�ੋਟਕੋੋਲ ਆਪਸ ਿਵਚ ਿਮਲ ਕ ੇਇੰਟਰਨă {ਟ �ਤੇ ਸੁਚੱਜਾ ਅਤ ੇਸੁਰੱਿਖਅਤ ਸੰਚਾਰ ਯਕੀਨੀ ਬਣਾ�ਦੇ ਹਨ। 
 
Q. Describe in detail the role of Internet protocol, Gopher, FTP and TCPIP protocols. (Nov 23),(Nov 23) 
Ans.  Internet protocols are essenƟal for communicaƟon over networks. They define how data is 
formaƩed, addressed, transmiƩed, and received. Each protocol has a specific role in ensuring smooth 
and secure data exchange. 
Internet Protocol (IP): IP is responsible for addressing and rouƟng data packets from the source to the 
desƟnaƟon across networks. Every device on the Internet has a unique IP address. IP ensures that data 
reaches the correct desƟnaƟon, even if it takes mulƟple paths. 
Gopher: Gopher is an early Internet protocol used for distribuƟng, searching, and retrieving documents. 
It presents informaƟon in a text-based, menu-driven interface, allowing users to browse files on remote 
servers. Although mostly replaced by the World Wide Web, it laid the groundwork for online data access 
systems. 
FTP (File Transfer Protocol): FTP is used for transferring files between computers over a network. It 
allows users to upload, download, and manage files on remote servers. FTP is essenƟal for website 
management and data sharing. 
TCP/IP (Transmission Control Protocol/Internet Protocol): TCP/IP is the core protocol suite of the 
Internet. TCP ensures reliable data delivery with error checking and reassembly, while IP manages 
addressing and rouƟng. Together, they enable accurate and secure communicaƟon between devices 
worldwide. 
ਇੰਟਰਨă {ਟ ਪ�ੋਟਕੋੋਲਸ (Internet Protocols) ਨă {ਟਵਰਕਸ ਰਾਹ� ਸੰਚਾਰ ਲਈ ਬਹੁਤ ਜ਼ਰੂਰੀ ਹਨ। ਇਹ ਿਨਯਮ ਿਦੰਦ ੇਹਨ ਿਕ 

ਡਾਟਾ ਿਕਵ� ਫਾਰਮਟੈ ਕੀਤਾ ਜ�ਦਾ ਹ,ੈ ਐਡਰ{ੈਸ ਕੀਤਾ ਜ�ਦਾ ਹ,ੈ ਭਿੇਜਆ ਜ�ਦਾ ਹ ੈਅਤ ੇਪ�ਾਪਤ ਕੀਤਾ ਜ�ਦਾ ਹ।ੈ ਹਰ ਪ�ੋਟੋਕਲੋ ਦਾ 

ਆਪਣਾ ਇੱਕ ਿਵਸ਼©ੇ ਕੰਮ ਹੁੰ ਦਾ ਹ ੈਜੋ ਡਾਟਾ ਦੀ ਸਚੱੁਜੀ ਅਤ ੇਸੁਰੱਿਖਅਤ ਅਦਾਨ-ਪ�ਦਾਨ ਨੰੂ ਯਕੀਨੀ ਬਣਾ�ਦਾ ਹ।ੈ 

 
Internet Protocol (IP): IP ਡਾਟਾ ਪੈਕੇਟ� ਨੰੂ ਸਰਤੋ ਤ� ਲੈ ਕ ੇਮੰਿਜ਼ਲ ਤੱਕ ਪਹੁੰ ਚਾਉਣ ਲਈ ਐਡਰ{ੈਿਸੰਗ ਅਤ ੇਰਾਊਿਟੰਗ ਕਰਦਾ 

ਹ।ੈ ਇੰਟਰਨă {ਟ 'ਤੇ ਹਰ ਿਡਵਾਈਸ ਦਾ ਇਕ ਯੂਨੀਕ IP ਐਡਰ{ੈਸ ਹੁੰ ਦਾ ਹ।ੈ IP ਇਹ ਯਕੀਨੀ ਬਣਾ�ਦਾ ਹ ੈਿਕ ਡਾਟਾ ਸਹੀ ਥ� ਪਹੁੰ ਚ,ੇ 

ਭਾਵ� ਉਸ ਦੇ ਲਈ ਕਈ ਰਸਤੇ ਲ�ਣ ੇਪੈਣ। 

 
Gopher: Gopher ਇਕ ਪੁਰਾਣਾ ਇੰਟਰਨă {ਟ ਪ�ੋਟੋਕਲੋ ਹ ੈਜੋ ਡੌਕਯੂਮ�ਟ� ਨੰੂ ਵੰਡਣ, ਲੱਭਣ ਅਤ ੇਪ�ਾਪਤ ਕਰਨ ਲਈ ਵਰਿਤਆ 

ਜ�ਦਾ ਸੀ। ਇਹ ਇੱਕ ਸਧਾਰਣ, ਮੈਨੂ-ਚਿਲਤ ਇੰਟਰਫੇਸ ਰਾਹ� ਜਾਣਕਾਰੀ ਿਦਖਾ�ਦਾ ਸੀ ਿਜਸ ਰਾਹ� ਯੂਜ਼ਰ ਦੂਜ ੇਸਰਵਰ� 'ਤ ੇ
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ਫਾਈਲ� ਨੰੂ ਬ�ਾਊਜ਼ ਕਰ ਸਕਦੇ ਸਨ। ਹਾਲ�ਿਕ ਹਣੁ ਇਸ ਦੀ ਥ� ਵੈ{ਬ ਨĂ  ਲੈ ਲਈ ਹ,ੈ ਪਰ ਇਹ ਆਨਲਾਈਨ ਡਾਟਾ ਐਕਸ{ੈਸ 

ਿਸਸਟਮ ਲਈ ਬਿੁਨਆਦ ਰਖਣ ਵਾਲਾ ਸੀ। 

 
FTP (File Transfer Protocol): FTP ਿਡਵਾਈਸ� ਿਵਚਕਾਰ ਫਾਈਲ� ਭੇਜਣ ਅਤ ੇਪ�ਾਪਤ ਕਰਨ ਲਈ ਵਰਿਤਆ ਜ�ਦਾ ਹ।ੈ ਇਸ 

ਰਾਹ� ਯੂਜ਼ਰ ਿਰਮਟੋ ਸਰਵਰ 'ਤ ੇਫਾਈਲ� ਅੱਪਲੋਡ, ਡਾਊਨਲੋਡ ਅਤ ੇਮੈਨĂ ਜ ਕਰ ਸਕਦੇ ਹਨ। ਇਹ ਵੈ{ਬਸਾਈਟ ਮਨੈĂ ਜਮ�ਟ ਅਤ ੇ

ਡਾਟਾ ਸ�ਝਾ ਕਰਨ ਲਈ ਬਹੁਤ ਜ਼ਰੂਰੀ ਹ।ੈ 

 
TCP/IP (Transmission Control Protocol / Internet Protocol): TCP/IP ਇੰਟਰਨă {ਟ ਦਾ ਮੁੱ ਖ ਪ�ੋਟੋਕੋਲ ਸੂਟ ਹ।ੈ TCP 

ਡਾਟਾ ਦੀ ਭਰੋਸਯੇੋਗ ਿਡਿਲਵਰੀ ਨੰੂ ਯਕੀਨੀ ਬਣਾ�ਦਾ ਹ ੈ— ਿਜਸ ਿਵੱਚ ਗਲਤੀ ਜ�ਚ ਅਤ ੇਡਾਟਾ ਦੀ ਦੁਬਾਰਾ ਜੋੜਾਈ ©ਾਮਲ 

ਹੁੰ ਦੀ ਹ।ੈ IP ਐਡਰ{ੈਿਸੰਗ ਅਤ ੇਰਾਊਿਟੰਗ ਦਾ ਕੰਮ ਕਰਦਾ ਹ।ੈ ਇਹ ਦੋਵ� ਿਮਲ ਕ ੇਦਨੁੀਆ ਭਰ ਦੀਆ ਂਿਡਵਾਈਸ� ਿਵਚਕਾਰ ਸਹੀ 

ਅਤ ੇਸੁਰੱਿਖਅਤ ਸੰਚਾਰ ਨੰੂ ਯਕੀਨੀ ਬਣਾ�ਦੇ ਹਨ। 
 
Q. Define the concept of web browsing. Write some of the browsers used in Internet. (Nov 24) 
Ans. Web browsing is the process of accessing and viewing informaƟon available on the World Wide 
Web using a soŌware applicaƟon called a web browser. It involves retrieving, displaying, and navigaƟng 
through web pages containing text, images, videos, and other mulƟmedia. Web browsing allows users 
to interact with websites, click hyperlinks, fill forms, download files, and access online services. 
The process begins when a user types a website address (URL) in the browser’s address bar. The browser 
then communicates with a Domain Name System (DNS) to translate the domain name into an IP 
address. This IP address helps locate the web server hosƟng the website. The browser uses HTTP or 
HTTPS protocols to request the web page from the server, which then sends the page content back to 
the browser for display. 
Some commonly used web browsers include: 

 Google Chrome – Known for speed, simplicity, and wide extension support. 
 Mozilla Firefox – Open-source browser with strong privacy and security features. 
 MicrosoŌ Edge – Windows-integrated browser with good performance. 
 Apple Safari – Default browser for Apple devices, opƟmized for macOS and iOS. 
 Opera – A feature-rich browser with a built-in VPN and ad-blocker. 

Web browsing is a fundamental acƟvity for exploring and using the Internet. 
ਵ{ੈਬ ਬ�ਾਊਿਜ਼ੰਗ (Web Browsing) ਇੱਕ ਪ�ਿਕਿਰਆ ਹ ੈਿਜਸ ਰਾਹ� ਵਰਤ�ਕਾਰ ਵਰਲਡ ਵਾਈਡ ਵੈ{ਬ 'ਤੇ ਉਪਲਬਧ ਜਾਣਕਾਰੀ 

ਤੱਕ ਪਹੁੰ ਚ ਤ ੇਉਹਨੰੂ ਦੇਖ ਸਕਦ ੇਹਨ। ਇਹ ਪ�ਿਕਿਰਆ ਵੈ{ਬ ਬ�ਾਊਜ਼ਰ ਨ� ਦ ੇਸਾਫਟਵੇਅਰ ਦੀ ਮਦਦ ਨਾਲ ਕੀਤੀ ਜ�ਦੀ ਹ।ੈ ਇਸ 

ਿਵੱਚ ਵੈ{ਬ ਪੇਜ� ਨੰੂ ਿਲਆਉਣਾ, ਿਦਖਾਉਣਾ ਅਤ ੇਉਨ� � ਿਵਚ ਨă ਵੀਗਟੇ ਕਰਨਾ ©ਾਮਲ ਹੁੰ ਦਾ ਹ,ੈ ਜੋ ਿਕ ਟੈਕਸਟ, ਿਚੱਤਰ, ਵੀਡੀਓ 

ਅਤ ੇਹੋਰ ਮਲਟੀਮੀਡੀਆ ਸਮੱਗਰੀ 'ਤੇ ਆਧਾਰਤ ਹੁੰ ਦ ੇਹਨ। 

ਵੈ{ਬ ਬ�ਾਊਿਜ਼ੰਗ ਦੌਰਾਨ ਯੂਜ਼ਰ ਵੈ{ਬਸਾਈਟ ਦਾ ਐਡਰ{ੈਸ (URL) ਬ�ਾਊਜ਼ਰ ਦੇ ਐਡਰ{ੈਸ ਬਾਰ ਿਵੱਚ ਿਲਖਦਾ ਹ।ੈ ਬ�ਾਊਜ਼ਰ ਪਿਹਲ� 

DNS (ਡੋਮੇਨ ਨĂ ਮ ਿਸਸਟਮ) ਨਾਲ ਸੰਪਰਕ ਕਰਦਾ ਹ ੈਜੋ ਡੋਮਨੇ ਨ� ਨੰੂ IP ਐਡਰ{ੈਸ ਿਵੱਚ ਤਬਦੀਲ ਕਰਦਾ ਹ।ੈ ਇਹ IP ਐਡਰ{ੈਸ 

ਸਾਈਟ ਦੇ ਸਰਵਰ ਨੰੂ ਲੱਭਣ ਿਵੱਚ ਮਦਦ ਕਰਦਾ ਹ।ੈ ਿਫਰ ਬ�ਾਊਜ਼ਰ HTTP ਜ� HTTPS ਪ�ੋਟੋਕਲੋ ਦੀ ਵਰਤ� ਕਰਕ ੇਸਰਵਰ ਤ� 

ਵੈ{ਬ ਪੇਜ ਦੀ ਬੇਨਤੀ ਕਰਦਾ ਹ,ੈ ਅਤ ੇਸਰਵਰ ਵਾਪਸ ਪੇਜ ਦੀ ਸਮੱਗਰੀ ਭੇਜਦਾ ਹ ੈਜੋ ਬ�ਾਊਜ਼ਰ ਿਵੱਚ ਿਦਖਾਈ ਜ�ਦੀ ਹ।ੈ 
ਅਕਸਰ ਵਰਤ ੇਜ�ਦ ੇਵ{ੈਬ ਬ�ਾਊਜ਼ਰ: • Google Chrome – ਤੇਜ਼ ਗਤੀ, ਸਧਾਰਣਤਾ ਅਤ ੇਵਧੀਆ ਐਕਸਟ�©ਨ ਸਿਹਯੋਗ ਲਈ 

ਮ©ਹੂਰ। 

• Mozilla Firefox – ਖੁੱ ਲ�ਾ ਸਰਤੋ ਬ�ਾਊਜ਼ਰ ਿਜਸ ਿਵੱਚ ਮਜ਼ਬੂਤ ਪ�ਾਈਵੇਸੀ ਅਤ ੇ ਸੁਰੱਿਖਆ ਿਵ©ੇ©ਤਾਵ� ਹਨ। 

• MicrosoŌ Edge – Windows ਨਾਲ ਇੰਟੀਗਰੇਟ ਕੀਤਾ ਹੋਇਆ ਤੇ ਿਬਹਤਰ ਪ�ਦਰ©ਨ ਵਾਲਾ ਬ�ਾਊਜ਼ਰ। 
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• Apple Safari – ਐਪਲ ਿਡਵਾਈਸ� ਲਈ ਿਡਫਾਲਟ ਬ�ਾਊਜ਼ਰ, ਜੋ macOS ਅਤ ੇiOS ਲਈ ਉਤਮ ਤਰੀਕ ੇਨਾਲ ਓਪਟੀਮਾਈਜ਼ 

ਕੀਤਾ ਿਗਆ ਹ।ੈ 

• Opera – ਇੱਕ ਫੀਚਰ-ਭਰਪਰੂ ਬ�ਾਊਜ਼ਰ ਿਜਸ ਿਵੱਚ ਇਨ-ਿਬਲਟ VPN ਅਤ ੇਐਡ-ਬਲਾਕਰ ਵੀ ਹ।ੈ 

ਸੰਖੇਪ ਿਵੱਚ, ਵੈ{ਬ ਬ�ਾਊਿਜ਼ੰਗ ਇੰਟਰਨă {ਟ ਦੀ ਖੋਜ ਅਤ ੇਉਪਯੋਗ ਲਈ ਇੱਕ ਮੂਲਭੂਤ ਗਿਤਿਵਧੀ ਹ।ੈ 

 
Q. What is www? Discuss working of WWW. (Nov 24),(Nov 19),(Nov 23) 
Ans. WWW (World Wide Web) is a system of interlinked hypertext documents and mulƟmedia content 
accessed via the Internet. It allows users to view web pages that may contain text, images, videos, and 
links to other pages, enabling easy navigaƟon and informaƟon retrieval. 
The WWW was invented by Tim Berners-Lee in 1989. It works based on technologies like HTTP 
(HyperText Transfer Protocol), HTML (HyperText Markup Language), URLs (Uniform Resource Locators), 
and web browsers. 
Working of WWW: 
When a user types a web address (URL) into a browser or clicks a hyperlink, the browser sends a request 
to a Domain Name System (DNS) to get the IP address of the web server hosƟng the desired content. 
Once the server is located, the browser uses the HTTP or HTTPS protocol to send a request to the server 
for the specific web page. 
The web server processes the request and sends back the required HTML page. The browser then 
interprets this HTML code and displays the page with formaƫng, images, and interacƟve features. 
Web pages are linked using hyperlinks, allowing users to jump from one document to another. This 
interconnected system is what makes the web a powerful tool for informaƟon sharing and 
communicaƟon. 
ਵਰਲਡ ਵਾਈਡ ਵ{ੈਬ (WWW) ਇੰਟਰਨă {ਟ ਰਾਹ� ਐਕਸ{ੈਸ ਕੀਤ ੇਜਾਣ ਵਾਲੇ ਹਾਈਪਰਟਕੈਸਟ ਡੌਕਮੂ�ਟਸ ਅਤ ੇਮਲਟੀਮੀਡੀਆ 

ਸਮੱਗਰੀ ਦੀ ਇਕ ਪਰਸਪਰ ਜੁੜੀ ਹੋਈ ਪ�ਣਾਲੀ ਹ।ੈ ਇਹ ਵਰਤ�ਕਾਰ� ਨੰੂ ਵੈ{ਬ ਪੇਜ ਵੇਖਣ ਦੀ ਆਿਗਆ ਿਦੰਦੀ ਹ,ੈ ਜੋ ਿਕ ਟੈਕਸਟ, 

ਿਚੱਤਰ, ਵੀਡੀਓ ਅਤ ੇਹੋਰ ਪੇਜ� ਨਾਲ ਜੁੜ ੇਿਲੰਕ (ਹਾਈਪਰਿਲੰਕਸ) ਰਾਹ� ਨă ਵੀਗੇਟ ਕਰਨ ਅਤ ੇਜਾਣਕਾਰੀ ਪ�ਾਪਤ ਕਰਨ ਦੀ 

ਸਹਲੂਤ ਿਦੰਦ ੇਹਨ। 

WWW ਦੀ ਖਜੋ ਿਟਮ ਬਰਨਰਜ਼-ਲੀ (Tim Berners-Lee) ਵੱਲ�  1989 ਿਵੱਚ ਕੀਤੀ ਗਈ ਸੀ। ਇਹ HTTP (HyperText 

Transfer Protocol), HTML (HyperText Markup Language), URL (Uniform Resource Locator), ਅਤ ੇਵੈ{ਬ 

ਬ�ਾਊਜ਼ਰ ਵਰਗੀਆ ਂਤਕਨੀਕ� 'ਤੇ ਆਧਾਿਰਤ ਹ।ੈ 
WWW ਿਕਵ� ਕੰਮ ਕਰਦਾ ਹੈ: ਜਦ� ਕੋਈ ਯੂਜ਼ਰ ਬ�ਾਊਜ਼ਰ ਿਵੱਚ ਵੈ{ਬ ਐਡਰ{ੈਸ (URL) ਿਲਖਦਾ ਹ ੈਜ� ਿਕਸ ੇਹਾਈਪਰਿਲੰਕ 'ਤ ੇ

ਕਿਲਕ ਕਰਦਾ ਹ,ੈ ਤ� ਬ�ਾਊਜ਼ਰ DNS (ਡੋਮੇਨ ਨĂ ਮ ਿਸਸਟਮ) ਨੰੂ ਿਰਕਵੈਸਟ ਭੇਜਦਾ ਹ ੈਤ� ਜੋ ਹੋਸਟ ਸਰਵਰ ਦਾ IP ਐਡਰ{ੈਸ 

ਲੱਿਭਆ ਜਾ ਸਕ।ੇ ਇੱਕ ਵਾਰ ਸਰਵਰ ਲੱਭ ਿਲਆ ਜ�ਦਾ ਹ,ੈ ਤ� ਬ�ਾਊਜ਼ਰ HTTP ਜ� HTTPS ਪ�ੋਟੋਕਲੋ ਰਾਹ� ਉਸ ਵ{ੈਬ ਪੇਜ ਦੀ 

ਿਰਕਵੈਸਟ ਭੇਜਦਾ ਹ।ੈ 

ਸਰਵਰ ਿਰਕਵੈਸਟ ਪ�ੋਸ{ੈਸ ਕਰਦਾ ਹ ੈਅਤ ੇHTML ਫਾਰਮਟੈ ਿਵੱਚ ਪੇਜ ਵਾਪਸ ਭੇਜਦਾ ਹ।ੈ ਬ�ਾਊਜ਼ਰ ਇਸ HTML ਕੋਡ ਨੰੂ ਪੜ� ਕ ੇ

ਫਾਰਮਿੈਟੰਗ, ਿਚੱਤਰ� ਅਤ ੇਇੰਟਰਐਕਿਟਵ ਫੀਚਰ� ਦੇ ਨਾਲ ਪੇਜ ਿਦਖਾ�ਦਾ ਹ।ੈ 
ਵੈ{ਬ ਪੇਜ ਹਾਈਪਰਿਲੰਕਸ ਰਾਹ� ਇੱਕ ਦੂਜ ੇਨਾਲ ਜੁੜ ੇਹੋਏ ਹੁੰ ਦ ੇਹਨ, ਜੋ ਵਰਤ�ਕਾਰ ਨੰੂ ਇਕ ਪੇਜ ਤ� ਦਜੂ ੇਪੇਜ 'ਤੇ ਆਸਾਨੀ ਨਾਲ 

ਜਾਣ ਦੀ ਆਿਗਆ ਿਦੰਦ ੇਹਨ। ਇਹੀ ਪਰਸਪਰ ਜੁੜ ੇਹੋਏ ਿਸਸਟਮ ਨੰੂ ਜਾਣਕਾਰੀ ਸ�ਝਾ ਕਰਨ ਅਤ ੇਸੰਚਾਰ ਲਈ ਇੱਕ ©ਕਤੀ©ਾਲੀ 

ਸਾਧਨ ਬਣਾ�ਦਾ ਹ।ੈ 
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Unit-2: MS Word 
Short Answer QuesƟons: 
 
Q. How find and replace are used for formaƫng in MS-word? (Nov 19) 
Ans. "Find and Replace" helps locate specific text and change it throughout the document. 
It is useful for formaƫng or correcƟng repeated words or styles quickly. 
"Find and Replace" ਿਕਸੇ ਡੌਕਮੂ�ਟ ਿਵੱਚ ਖਾਸ ©ਬਦ ਲੱਭਣ ਅਤੇ ਉਸਨੰੂ ਸਾਰੇ ਡੌਕਮੂ�ਟ ਿਵੱਚ ਬਦਲਣ ਿਵੱਚ ਮਦਦ ਕਰਦਾ 

ਹੈ। ਇਹ ਦੁਹਰਾਏ ਹੋਏ ©ਬਦ� ਜ� ਸਟਾਈਲ� ਨੰੂ ਜਲਦੀ直 ਠੀਕ ਕਰਨ ਜ� ਫਾਰਮਟੈ ਕਰਨ ਲਈ ਲਾਭਕਾਰੀ ਹੁੰ ਦਾ ਹ।ੈ 

 
Q. What are smart documents? (Nov 19), (Nov 23) 
Ans. Smart documents contain built-in intelligence like XML data and controls. 
They allow automaƟon and dynamic interacƟon with user inputs. 
ਸਮਾਰਟ ਡੌਕੂਮ�ਟ� ਿਵੱਚ XML ਡਟੇਾ ਅਤੇ ਕੰਟਰੋਲ ਵ�ਗ ਆੰਤਰੀਕ ਸਮਰੱਥਾ ਹੰੁਦੀ ਹੈ। 

ਇਹ ਯੂਜ਼ਰ ਦੇ ਇਨਪੁੱ ਟ ਅਨੁਸਾਰ ਆਟੋਮ©ੇਨ ਅਤ ੇਗਤੀ©ੀਲ ਪਰਸਪਰ ਕਰਵਾਈ ਦੀ ਇਜਾਜ਼ਤ ਿਦੰਦ ੇਹਨ। 

 
Q. MS-Word features (Nov 23) 
Ans. MS Word offers features like spell check, templates, mail merge, and formaƫng tools. 
It simplifies document creaƟon, ediƟng, and sharing. 
MS Word ਇਮਿਲਆਂ ਜ� ਡੌਕੂਮ�ਟ� ਬਣਾਉਣ, ਸੰਪਾਦਨ ਕਰਨ ਅਤ ੇ ਸ�ਝ ੇ ਕਰਨ ਨੰੂ ਆਸਾਨ ਬਣਾ�ਦਾ ਹੈ। 

ਇਸ ਿਵੱਚ ਸਪੈਲ ਚੈਕ, ਟ�ਪਲੇਟਸ, ਮੇਲ ਮਰਜ ਅਤ ੇਫਾਰਮਿੈਟੰਗ ਟੂਲਜ਼ ਵਰਗੀਆ ਂਿਵ©ੇ©ਤਾਵ� ©ਾਮਲ ਹਨ। 
 
Q. Word Document features (Nov 23) 
Ans. A Word document supports images, tables, hyperlinks, headers/footers, and styles. 
It provides rich formaƫng and layout opƟons for professional documents. 
ਇੱਕ ਵਰਡ ਡੌਕੂਮ�ਟ ਿਵੱਚ ਿਚੱਤਰ, ਟਬੇਲ�, ਹਾਈਪਰਿਲੰਕ, ਹੈਡਰ/ਫੁੱ ਟਰ ਅਤ ੇ ਸਟਾਈਲ ©ਾਮਲ ਹੋ ਸਕਦ ੇ ਹਨ। 

ਇਹ ਪ©ੇੇਵਰ ਡੌਕੂਮ�ਟ� ਲਈ ਿਰਚ ਫਾਰਮਿੈਟੰਗ ਅਤ ੇਲੇਆਉਟ ਦੇ ਿਵਕਲਪ ਪ�ਦਾਨ ਕਰਦਾ ਹ।ੈ 

 
Q. Write the need of Page margins. (Nov 24) 
Ans. Page margins ensure text doesn’t touch the edge of the paper and improves readability. 
They also allow space for binding or annotaƟons. 
ਪੇਜ਼ ਮਾਰਿਜਨ ਇਹ ਯਕੀਨੀ ਬਣਾ�ਦ ੇਹਨ ਿਕ ਿਲਖਤ ਕਾਗਜ਼ ਦ ੇਕੋਨĂ  ਨੰੂ ਨਾ ਛੂਹੇ ਅਤ ੇਇਹ ਪਾਠਨ ਯੋਗਤਾ ਿਵੱਚ ਸੁਧਾਰ 

ਕਰਦ ੇਹਨ। ਇਹ ਬਾਈਿਂਡੰਗ ਜ� ਿਟੱਪਣੀਆਂ ਲਈ ਵੀ ਥ� ਮੁਹੱਈਆ ਕਰਦ ੇਹਨ। 
 
Q. What do you mean by macros? How macros are created in MS-Word? (Nov 19) 
Ans. Macros are recorded sequences of acƟons to automate repeƟƟve tasks. 
They can be created via "View → Macros → Record Macro" opƟon in MS Word. 
ਮੈਕਰੋਜ਼ ਉਹ ਦਰਜ ਕੀਤੀਆਂ ਕਾਰਵਾਈਆਂ ਹਨ ਜ ੋ ਦਹੁਰਾਏ ਜਾਣ ਵਾਲੇ ਕੰਮ� ਨੰੂ ਆਟਮੈੋਟ ਕਰਦ ੇ ਹਨ। 

ਇਹ MS Word ਿਵੱਚ "View → Macros → Record Macro" ਿਵਕਲਪ ਰਾਹ� ਬਣਾਏ ਜਾ ਸਕਦੇ ਹਨ। 

 
Long Answer QuesƟons: 
2. Explain the following features of MS Word with suitable example. (Nov 19) 
a) Mail-merge (Nov 23) 
b) Header and Footer (Nov 23) 
 
Ans. a) Mail Merge: Mail Merge is a feature in MS Word used to generate mulƟple documents with 
personalized content. It combines a main document (like a leƩer or email) with a data source (such as 
an Excel file or Word table) that contains names, addresses, or other variables. For example, a company 
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can write one invitaƟon leƩer and send it to 100 people, with each leƩer customized using their names 
and addresses. 
Steps to use Mail Merge: 

 Go to the Mailings tab → Select Start Mail Merge 
 Choose the document type (leƩers, emails, etc.) 
 Select recipients from a data file 
 Insert merge fields (e.g., <<Name>>, <<Address>>) 
 Preview and finish the merge 

b) Header and Footer: The Header appears at the top and the Footer at the boƩom of each page in a 
Word document. These secƟons are used to display repeaƟng informaƟon like page numbers, document 
Ɵtle, date, or author name. For example, adding "Class Notes – MS Word" in the header and page 
numbers in the footer ensures consistency across all pages. 
To use: 
Go to Insert → Select Header or Footer, choose a style, and enter the desired text. Headers and footers 
enhance the professionalism and structure of a document. 
a) ਮੇਲ ਮਰਜ (Mail Merge): ਮੇਲ ਮਰਜ MS Word ਦੀ ਇੱਕ ਿਵ©ੇ©ਤਾ ਹ ੈਜੋ ਿਨ{ਜੀਿਕ�ਤ ਸਮੱਗਰੀ ਨਾਲ ਕਈ ਦਸਤਾਵੇਜ਼ 

ਬਣਾਉਣ ਲਈ ਵਰਤੀ ਜ�ਦੀ ਹ।ੈ ਇਹ ਇੱਕ ਮੁੱ ਖ ਦਸਤਾਵੇਜ਼ (ਿਜਵ� ਿਕ ਿਚੱਠੀ ਜ� ਈਮਲੇ) ਨੰੂ ਇੱਕ ਡਾਟਾ ਸਰਤੋ (Excel ਫਾਈਲ ਜ� 

Word ਟਬੇਲ) ਨਾਲ ਜੋੜਦੀ ਹ ੈ ਿਜਸ ਿਵੱਚ ਨਾਮ, ਪਤ ੇਜ� ਹੋਰ ਵੇਰੀਏਬਲ ਹੁੰ ਦ ੇਹਨ। ਉਦਾਹਰਨ ਵਜ�, ਇੱਕ ਕੰਪਨੀ ਇੱਕ 

ਿਨਮੰਤਰਣ ਿਚੱਠੀ ਿਤਆਰ ਕਰ ਸਕਦੀ ਹ ੈਅਤ ੇਉਸ ੇ ਿਚੱਠੀ ਨੰੂ 100 ਵੱਖ-ਵੱਖ ਿਵਅਕਤੀਆਂ ਨੰੂ ਉਨ� � ਦ ੇਨ� ਅਤ ੇਪਿਤਆ ਂਨਾਲ 

ਿਨ{ਜੀਿਕ�ਤ ਕਰਕ ੇਭੇਜ ਸਕਦੀ ਹ।ੈ 

Mail Merge ਵਰਤਣ ਦ ੇਕਦਮ: 

 Mailings ਟਬੈ 'ਤੇ ਜਾਓ → Start Mail Merge ਚੁਣ ੋ

 ਦਸਤਾਵੇਜ਼ ਿਕਸਮ ਚਣੁ ੋ(leƩers, emails ਆਿਦ) 

 ਡਾਟਾ ਫਾਈਲ ਤ� recipients ਚਣੁ ੋ

 Merge fields ਿਜਵ� <<Name>>, <<Address>> ©ਾਿਮਲ ਕਰ ੋ

 Preview ਕਰ ੋਅਤ ੇMerge ਖਤਮ ਕਰ ੋ

 
b) ਹੈਡਰ ਅਤ ੇਫਟੁਰ (Header and Footer):  Word ਦਸਤਾਵਜ਼ੇ ਿਵੱਚ Header ਪੇਜ਼ ਦ ੇ�ਪਰ ਅਤ ੇFooter ਹੇਠ� ਿਦਖਾਈ 

ਿਦੰਦ ੇਹਨ। ਇਹ ਸੈਕ©ਨ ਮੁੜ ਮੜੁ ਆਉਣ ਵਾਲੀ ਜਾਣਕਾਰੀ ਿਦਖਾਉਣ ਲਈ ਵਰਤ ੇਜ�ਦੇ ਹਨ, ਿਜਵ� ਿਕ ਪੇਜ਼ ਨੰਬਰ, ਦਸਤਾਵੇਜ਼ 

ਦਾ ਿਸਰਲੇਖ, ਿਮਤੀ ਜ� ਲੇਖਕ ਦਾ ਨ�। ਉਦਾਹਰਨ ਵਜ�, "Class Notes – MS Word" ਨੰੂ Header ਿਵੱਚ ਅਤ ੇFooter ਿਵੱਚ 

ਪੇਜ਼ ਨੰਬਰ ©ਾਿਮਲ ਕਰਕ ੇਸਾਰ ੇਪਜ਼ੇ� ਿਵੱਚ ਇੱਕਸਾਰਤਾ ਬਣਾਈ ਜਾ ਸਕਦੀ ਹ।ੈ 

ਵਰਤਣ ਦਾ ਤਰੀਕਾ: Insert → Header ਜ� Footer ਚੁਣ,ੋ ਇੱਕ ©ੈਲੀ ਚਣੁ ੋ ਅਤ ੇ ਚਾਹੀਦਾ ਪਾਠ ਿਲਖ।ੋ 

Header ਅਤ ੇFooter ਦਸਤਾਵਜ਼ੇ ਦੀ ਪ©ੇਕ© ਅਤ ੇਸੰਰਚਨਾ ਨੰੂ ਸੁਧਾਰਦ ੇਹਨ। 
 
Q. What is mail merge? Write the procedure for mail merging. (Nov 24) 
Ans. Mail Merge is a powerful feature in MS Word used to create mulƟple personalized documents, 
such as leƩers, emails, envelopes, or labels, by combining a standard template with a data source. This 
allows users to send the same document to many recipients, with specific details (like name, address, 
etc.) automaƟcally filled in. 
For example, if a company wants to send an invitaƟon leƩer to 100 clients, mail merge can insert each 
client’s name and address into the leƩer automaƟcally. 
Procedure for Mail Merging: 

1. Open MS Word and create the main document (leƩer, invitaƟon, etc.). 
2. Go to the Mailings tab and click Start Mail Merge, then select the type of document (LeƩers, 

Emails, etc.). 
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3. Click Select Recipients → Choose Use an ExisƟng List or create a new list (Excel, Word table, or 
Outlook contacts). 

4. Place the cursor where you want to insert fields and click Insert Merge Field (e.g., Name, 
Address). 

5. Click Preview Results to see how the merged data will appear in the document. 
6. Click Finish & Merge → Choose to Print or Edit Individual Documents. 

Mail Merge saves Ɵme and ensures consistency when sending bulk personalized communicaƟons. 
ਮੇਲ ਮਰਜ (Mail Merge) MicrosoŌ Word ਦੀ ਇੱਕ ©ਕਤੀ©ਾਲੀ ਿਵ©ੇ©ਤਾ ਹ ੈ ਜੋ ਿਨ{ਜੀਿਕ�ਤ ਦਸਤਾਵੇਜ਼� (ਿਜਵ� ਿਕ 

ਿਚੱਠੀਆ,ਂ ਈਮੇਲ, ਲੇਬਲ ਜ� ਿਲਫਾਫੇ) ਨੰੂ ਇੱਕ ਹੀ ਟੈਮਪਲੇਟ ਅਤ ੇਡਾਟਾ ਸਰਤੋ ਨੰੂ ਜੋੜ ਕ ੇਿਤਆਰ ਕਰਨ ਿਵੱਚ ਵਰਤੀ ਜ�ਦੀ ਹ।ੈ 
ਇਸ ਨਾਲ ਇੱਕ ੋਦਸਤਾਵੇਜ਼ ਨੰੂ ਕਈ ਲੋਕ� ਨੰੂ ਭੇਿਜਆ ਜਾ ਸਕਦਾ ਹ,ੈ ਿਜੱਥ ੇਹਰ ਿਵਅਕਤੀ ਲਈ ਨ�, ਪਤਾ ਆਿਦ ਜਾਣਕਾਰੀ ਆਪਣ ੇ

ਆਪ ਭਰ ਜ�ਦੀ ਹ।ੈ 

ਉਦਾਹਰਨ ਵਜ�: ਜੇਕਰ ਇੱਕ ਕੰਪਨੀ 100 ਗਾਹਕ� ਨੰੂ ਿਨਮੰਤਰਣ ਿਚੱਠੀ ਭੇਜਣਾ ਚਾਹੁੰ ਦੀ ਹ,ੈ ਤ� Mail Merge ਹਰ ਿਚੱਠੀ ਿਵੱਚ 

ਗਾਹਕ ਦਾ ਨ� ਅਤ ੇਪਤਾ ਆਪ ੇ©ਾਿਮਲ ਕਰ ਦ�ਦਾ ਹ।ੈ 

 
Mail Merge ਦੀ ਪ�ਿਕਿਰਆ: 

1. MS Word ਖੋਲ�ੋ  ਅਤ ੇਮੁੱ ਖ ਦਸਤਾਵੇਜ਼ ਬਣਾਓ (ਿਜਵ� ਿਚੱਠੀ ਜ� ਿਨਮੰਤਰਣ)। 

2. Mailings ਟਬੈ ਤੇ ਜਾਓ → Start Mail Merge ਤੇ ਕਿਲੱਕ ਕਰ ੋ→ ਦਸਤਾਵੇਜ਼ ਦੀ ਿਕਸਮ ਚੁਣੋ (LeƩers, Emails 

ਆਿਦ)। 
3. Select Recipients ਤੇ ਕਿਲੱਕ ਕਰ ੋ→ "Use an ExisƟng List" ਚਣੁ ੋਜ� ਨਵ� ਿਲਸਟ ਬਣਾਓ (Excel, Word Table 

ਜ� Outlook Contacts)। 

4. ਿਜੱਥ ੇਫੀਲਡ ©ਾਿਮਲ ਕਰਨੀ ਹ ੈ�ਥੇ ਕਰਸਰ ਰੱਖ ੋ→ Insert Merge Field 'ਚ� "Name", "Address" ਆਿਦ ਚੁਣੋ। 

5. Preview Results 'ਤ ੇਕਿਲੱਕ ਕਰਕ ੇਵੇਖ ੋਿਕ ਡਾਟਾ ਿਕਵ� ਆਵੇਗਾ। 

6. Finish & Merge → "Print" ਜ� "Edit Individual Documents" ਚੁਣੋ। 

 
ਨਤੀਜਾ: Mail Merge ਸਮ� ਬਚਾ�ਦਾ ਹ ੈਅਤ ੇਵੱਡੀ ਿਗਣਤੀ ਿਵੱਚ ਿਨ{ਜੀਿਕ�ਤ ਦਸਤਾਵੇਜ਼ ਭੇਜਣ ਸਮ� ਇੱਕਸਾਰਤਾ ਬਰਕਰਾਰ 

ਰੱਖਦਾ ਹ।ੈ 

 
Q. Discuss the concept of text and tables in MS Word. (Nov 24) 
Ans. Text and tables are two fundamental elements used in MS Word to create structured and readable 
documents. 
Text refers to the wriƩen content in a document. MS Word provides a wide range of formaƫng tools to 
enhance text appearance, such as changing font style, size, color, alignment, line spacing, and applying 
styles like bold, italic, and underline. Users can also insert bullet points, numbering, and hyperlinks. Text 
can be organized into paragraphs, columns, and secƟons for beƩer readability and presentaƟon. 
Tables in MS Word are used to organize data in rows and columns. They are helpful for displaying 
informaƟon like schedules, price lists, comparisons, or reports in a structured format. Tables can be 
created using the Insert → Table opƟon, where users can select the number of rows and columns 
needed. Once inserted, tables can be customized using features like merging cells, adjusƟng column 
widths, applying borders, and adding shading. 
Combining text and tables allows users to present informaƟon clearly and professionally. For example, 
in a report, paragraphs of explanaƟon can be followed by a table of data. MS Word's flexibility makes it 
easy to manage both text and tables efficiently for various types of documents. 
ਪਾਠ (Text) ਅਤ ੇਟਬੇਲ (Tables) MS Word ਿਵੱਚ ਦਸਤਾਵੇਜ਼ ਬਣਾਉਣ ਦ ੇਦੋ ਮੁੱ ਖ ਤੱਤ ਹਨ ਜੋ ਦਸਤਾਵੇਜ਼ ਨੰੂ ਢੰਗ ਨਾਲ 

ਸੁਚੱਜਾ ਅਤ ੇਪੜ�ਨਯੋਗ ਬਣਾ�ਦ ੇਹਨ। 
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ਪਾਠ ਨਾਲ ਭਾਵ ਦਸਤਾਵੇਜ਼ ਿਵੱਚ ਿਲਖੀ ਗਈ ਜਾਣਕਾਰੀ ਨਾਲ ਹ।ੈ MS Word ਵੱਖ-ਵੱਖ ਫਾਰਮਿੇਟੰਗ ਟੂਲਜ਼ ਿਦੰਦਾ ਹ,ੈ ਿਜਵ� ਫ�ਟ 

ਦੀ ©ੈਲੀ, ਅਕਾਰ, ਰੰਗ, ਅਲਾਈਨਮ�ਟ, ਲਾਈਨ ਸਪਿੇਸੰਗ ਬਦਲਣਾ, ਅਤ ੇਿਲਖਤ ਿਵੱਚ bold, italic, underline ਵਰਗੀ ©ੈਲੀਆ ਂ

ਲਗਾਉਣਾ। ਯੂਜ਼ਰ ਬਲੇੁਟ ਪੋਇੰਟ, ਨੰਬਿਰੰਗ ਅਤ ੇਹਾਇਪਰਿਲੰਕ ਵੀ ਜੋੜ ਸਕਦ ੇਹਨ। ਪਾਠ ਨੰੂ ਪੈਰਾਗ�ਾਫ�, ਕਾਲਮ� ਅਤ ੇਭਾਗ� 

ਿਵੱਚ ਵੰਿਡਆ ਜਾ ਸਕਦਾ ਹ,ੈ ਿਜਸ ਨਾਲ ਪੜ�ਨ ਿਵੱਚ ਸੁਿਵਧਾ ਿਮਲਦੀ ਹ।ੈ 

ਟੇਬਲ� MS Word ਿਵੱਚ ਡਾਟਾ ਨੰੂ ਕਤਾਰ� ਅਤ ੇਕਾਲਮ� ਿਵੱਚ ਠੀਕ ਢੰਗ ਨਾਲ ਦਰਸਾਉਣ ਲਈ ਵਰਤੀਆ ਂਜ�ਦੀਆ ਂਹਨ। ਇਹ 

ਸਮ�-ਸੂਚੀਆ,ਂ ਕੀਮਤ ਸਚੂੀਆ,ਂ ਤਲੁਨਾਵ� ਜ� ਿਰਪਰੋਟ� ਵਰਗੇ ਡਾਟਾ ਨੰੂ ਿਵਵਸਿਥਤ ਢੰਗ ਨਾਲ ਿਦਖਾਉਣ ਲਈ ਸਹਾਇਕ ਹੁੰ ਦੀਆ ਂ

ਹਨ। Insert → Table ਿਵਅਕਲਪ ਰਾਹ� ਟੇਬਲ ਬਣਾਈ ਜਾ ਸਕਦੀ ਹ,ੈ ਿਜੱਥ ੇਯੂਜ਼ਰ ਲੋੜ ਅਨੁਸਾਰ ਕਤਾਰ� ਅਤ ੇਕਾਲਮ� ਦੀ 

ਿਗਣਤੀ ਚਣੁ ਸਕਦੇ ਹਨ। ਟੇਬਲ ਬਣਾਉਣ ਤ� ਬਾਅਦ, ਯੂਜ਼ਰ ਸ{ੈਲ ਮਰਜ ਕਰ ਸਕਦ ੇਹਨ, ਕਾਲਮ ਦੀ ਚੜੌਾਈ ਅਨੁਕਲੂ ਕਰ 

ਸਕਦ ੇਹਨ, ਬਾਰਡਰ ਲਗਾ ਸਕਦ ੇਹਨ ਅਤ ੇ©ੇਿਡੰਗ ਵੀ ਜੋੜ ਸਕਦ ੇਹਨ। 

ਪਾਠ ਅਤ ੇਟੇਬਲ ਨੰੂ ਿਮਲਾ ਕੇ ਜਾਣਕਾਰੀ ਨੰੂ ਸਾਫ਼ ਅਤ ੇਪ©ੇੇਵਰ ਢੰਗ ਨਾਲ ਦਰਸਾਇਆ ਜਾ ਸਕਦਾ ਹ।ੈ ਉਦਾਹਰਨ ਵਜ�, ਿਕਸ ੇ

ਿਰਪਰੋਟ ਿਵੱਚ ਪਿਹਲ� ਪੈਰਾਗ�ਾਫ ਰਾਹ� ਿਵਆਿਖਆ ਿਦੱਤੀ ਜਾ ਸਕਦੀ ਹ ੈਅਤ ੇਿਫਰ ਡਾਟਾ ਲਈ ਟਬੇਲ ਿਦੱਤੀ ਜਾ ਸਕਦੀ ਹ।ੈ MS 

Word ਦੀ ਲਚੀਲਤਾ ਇਸਨੰੂ ਵੱਖ-ਵੱਖ ਿਕਸਮ ਦ ੇਦਸਤਾਵੇਜ਼� ਲਈ ਪਾਠ ਅਤ ੇਟੇਬਲ ਦੋਹ� ਨੰੂ ਬਖਬੂੀ ਪ�ਬੰਿਧਤ ਕਰਨ ਯੋਗ 

ਬਣਾ�ਦੀ ਹ।ੈ 

 
Q. How you can insert a table in your document? Discuss various opƟons available for working with 
tables. (Nov 19) 
Ans. InserƟng a table in MS Word is simple and helps organize data in rows and columns. To insert a 
table, go to the Insert tab on the Ribbon and click Table. A dropdown grid appears where you can select 
the number of rows and columns. AlternaƟvely, you can choose Insert Table for a custom size or use 
Draw Table to create a table manually. 
Once a table is inserted, Word provides several tools for working with it under the Table Tools tab, which 
includes Design and Layout opƟons. 
OpƟons for working with tables: 

1. Adding/DeleƟng Rows and Columns: Use the Layout tab to insert or delete rows and columns 
as needed. 

2. Merging/Spliƫng Cells: Cells can be merged or split to adjust the structure of the table. 
3. Formaƫng: Use the Design tab to apply table styles, shading, borders, and header row 

formaƫng. 
4. Aligning Text: Text inside cells can be aligned (top, center, boƩom) and jusƟfied. 
5. SorƟng and CalculaƟons: Tables can sort data alphabeƟcally or numerically and perform basic 

calculaƟons. 
Tables are useful for organizing data, comparing values, or creaƟng schedules within a Word document. 
MS Word ਿਵੱਚ ਟੇਬਲ ਇਨਸਰਟ ਕਰਨਾ ਆਸਾਨ ਹ ੈਅਤ ੇਇਹ ਡਾਟਾ ਨੰੂ ਕਤਾਰ� ਅਤ ੇਕਾਲਮ� ਿਵੱਚ ਢੰਗ ਨਾਲ ਿਵਵਸਿਥਤ 

ਕਰਨ ਿਵੱਚ ਮਦਦ ਕਰਦਾ ਹ।ੈ 

ਟੇਬਲ ਇਨਸਰਟ ਕਰਨ ਦੀ ਿਵਧੀ: Ribbon ਿਵੱਚ� Insert ਟਬੈ 'ਤੇ ਜਾਓ ਅਤ ੇTable 'ਤ ੇਕਿਲਕ ਕਰ।ੋ ਇੱਕ ਡ�ਾਪਡਾਊਨ ਿਗ�ਡ 

ਨਜ਼ਰ ਆਵੇਗਾ, ਿਜੱਥ� ਤੁਸ� ਕਤਾਰ� ਅਤ ੇਕਾਲਮ� ਦੀ ਿਗਣਤੀ ਚਣੁ ਸਕਦੇ ਹ।ੋ ਤੁਸ� Insert Table ਚੁਣ ਕ ੇਆਪਣੀ ਲੋੜ ਮਤੁਾਬਕ 

ਸਾਈਜ਼ ਦ ੇਸਕਦ ੇਹ ੋਜ� Draw Table ਦੀ ਵਰਤ� ਕਰਕ ੇਹੱਥ�-ਨਾਲ ਟਬੇਲ ਬਣਾਉਣੀ ਹੋਵ ੇਤ� ਕਰ ਸਕਦ ੇਹ।ੋ 

MS Word ਿਵੱਚ ਟੇਬਲ ਲਈ ਉਪਲਬਧ ਿਵਕਲਪ: 

1. Rows ਅਤ ੇColumns ਜੜੋਣਾ ਜ� ਹਟਾਉਣਾ: Layout ਟੈਬ ਰਾਹ� ਨਵੀਆ ਂਕਤਾਰ� ਜ� ਕਾਲਮ ਜੋੜ ੇਜ� ਹਟਾਏ ਜਾ 

ਸਕਦ ੇਹਨ। 
2. Cells Merge/Split ਕਰਨਾ: ਕਈ ਸ{ੈਲ ਇੱਕ ਿਵੱਚ ਿਮਲਾ ਸਕਦ ੇਹ ੋਜ� ਇੱਕ ਸ{ੈਲ ਨੰੂ ਵੱਖ ਕਰ ਸਕਦੇ ਹ,ੋ ਿਜਸ ਨਾਲ 

ਟੇਬਲ ਦੀ ਬਣਤਰ ਨੰੂ ਸੋਿਧਆ ਜਾ ਸਕਦਾ ਹ।ੈ 
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3. Formaƫng:Design  ਟਬੈ ਰਾਹ� ਟੇਬਲ ਸਟਾਈਲ, ©ੇਿਡੰਗ, ਬਾਰਡਰ, ਅਤ ੇਹ{ੈਡਰ ਰ ੋਦਾ ਫਾਰਮਟੈ ਬਦਲ ਸਕਦੇ ਹ।ੋ 

4. Text Alignment: ਸ{ੈਲ� ਿਵੱਚ ਿਲਖਤ ਨੰੂ ਟੌਪ, ਸ�ਟਰ ਜ� ਬਾਟਮ ਅਲਾਈਨ ਕੀਤਾ ਜਾ ਸਕਦਾ ਹ।ੈ 
5. SorƟng ਅਤੇ CalculaƟons: ਟਬੇਲ ਿਵੱਚ ਮੌਜੂਦ ਡਾਟਾ ਨੰੂ ਅਲਫਾਬੈਿਟਕਲ ਜ� ਨੰਬਰ ਅਨੁਸਾਰ ਸਰੌਟ ਕੀਤਾ ਜਾ 

ਸਕਦਾ ਹ ੈਅਤ ੇਕੁਝ ਮਲੂ ਗਣਨਾਵ� (ਿਜਵ� ਜੋੜ) ਵੀ ਕੀਤੀਆ ਂਜਾ ਸਕਦੀਆ ਂਹਨ। 
ਟੇਬਲ� ਿਰਪਰੋਟ�, ਸਮ�-ਸੂਚੀਆ,ਂ ਮੁਲ�ਿਵਆ,ਂ ਜ� ਿਕਸ ੇਵੀ ਤਰ�� ਦੀ ਜਾਣਕਾਰੀ ਨੰੂ ਿਵਵਸਿਥਤ ਢੰਗ ਨਾਲ ਦਰਸਾਉਣ ਲਈ ਬਹਤੁ 

ਲਾਭਦਾਇਕ ਹੁੰ ਦੀਆ ਂਹਨ। 
 
Q. Write a short note on images and tables opƟons in MicrosoŌ Word. (Nov 23) 
Ans.  In MicrosoŌ Word, images and tables play a vital role in enhancing the presentaƟon and 
structure of a document. 
Images can be inserted into a document to support the content visually. To insert an image, go to the 
Insert tab and click Pictures to add from your device, or choose Online Pictures to search from the web. 
Once inserted, Word provides various formaƫng opƟons such as resizing, cropping, applying borders, 
adjusƟng brightness/contrast, and wrapping text around the image using layout opƟons like Square, 
Tight, or Behind Text. These features make it easy to posiƟon and style images as needed. 
Tables are used to organize and present data in rows and columns. To insert a table, go to Insert → 
Table, then select the desired size. AŌer inserƟng, Word offers tools to format the table through the 
Table Tools → Design and Layout tabs. You can apply table styles, change borders, merge or split cells, 
and align text within cells. You can also insert or delete rows/columns and sort data. 
Using images and tables helps make documents more interacƟve, clear, and professional, especially in 
reports, newsleƩers, and academic or business content. 
ਮਾਈਕਰੋਸਫੌਟ ਵਰਡ ਿਵੱਚ ਿਚੱਤਰ ਅਤ ੇਟੇਬਲ ਇੱਕ ਦਸਤਾਵਜ਼ੇ ਦੀ ਪ�ਸਤਤੁੀ ਅਤ ੇਬਣਤਰ ਨੰੂ ਵਧੀਆ ਬਣਾਉਣ ਿਵੱਚ 

ਮਹੱਤਵਪੂਰਨ ਭੂਿਮਕਾ ਿਨਭਾ�ਦੇ ਹਨ। 

ਿਚੱਤਰ (Images): ਿਚੱਤਰ ਸਮੱਗਰੀ ਨੰੂ ਿਵਜ਼ੂਅਲ ਤਰੀਕ ੇਨਾਲ ਸਮਝਾਉਣ ਿਵੱਚ ਮਦਦ ਕਰਦੇ ਹਨ। ਿਚੱਤਰ ਇਨਸਰਟ ਕਰਨ 

ਲਈ Insert ਟੈਬ ਿਵੱਚ� Pictures 'ਤ ੇਕਿਲਕ ਕਰ ੋਿਜੱਥ� ਤੁਸ� ਆਪਣੇ ਕੰਿਪਊਟਰ ਤ� ਿਚੱਤਰ ਲੋਡ ਕਰ ਸਕਦ ੇਹ ੋਜ� Online 

Pictures ਰਾਹ� ਇੰਟਰਨă ਟ ਤ� ਲੱਭ ਸਕਦ ੇਹ।ੋ ਿਚੱਤਰ ਇਨਸਰਟ ਹੋਣ ਤ� ਬਾਅਦ, ਤੁਸ� ਉਨ� � ਨੰੂ ਰੀਸਾਈਜ਼, ਕਰੋਪ, ਬਾਰਡਰ 

ਲਗਾਉਣ, ਚਮਕ/ਕੰਟਰਾਸਟ ਠੀਕ ਕਰਨ ਜ� ਲੇਆਉਟ ਿਵਕਲਪ� (ਿਜਵ� Square, Tight, Behind Text) ਨਾਲ ਟੈਕਸਟ ਦ ੇ

ਆਸ-ਪਾਸ ਰੱਖ ਸਕਦੇ ਹ।ੋ 

ਟੇਬਲ (Tables): ਟਬੇਲ ਡਾਟਾ ਨੰੂ ਕਤਾਰ� ਅਤ ੇਕਾਲਮ� ਿਵੱਚ ਿਵਅਵਸਿਥਤ ਕਰਨ ਲਈ ਵਰਤ ੇਜ�ਦ ੇਹਨ। ਟੇਬਲ ਇਨਸਰਟ 

ਕਰਨ ਲਈ Insert → Table ਦੀ ਵਰਤ� ਕਰ ੋਅਤ ੇਲੋੜੀਦ ੇਅਕਾਰ ਦੀ ਚੋਣ ਕਰ।ੋ ਟੇਬਲ ਇਨਸਰਟ ਹਣੋ ਤ� ਬਾਅਦ, Table Tools 

→ Design ਅਤ ੇLayout ਟਬੈ� ਰਾਹ� ਤੁਸ� ਟੇਬਲ ਦਾ ਫਾਰਮਟੈ ਬਦਲ ਸਕਦੇ ਹ,ੋ ਸ{ੈਲ ਿਮਲਾ ਜ� ਵੱਖ ਕਰ ਸਕਦੇ ਹ,ੋ ਬਾਰਡਰ, 

©ੇਿਡੰਗ, ਅਤ ੇਅੰਦਰਲੀ ਿਲਖਤ ਦੀ ਅਲਾਈਨਮ�ਟ ਬਦਲ ਸਕਦ ੇਹ।ੋ ਤੁਸ� ਕਤਾਰ� ਜ� ਕਾਲਮ� ਨੰੂ ਜੋੜ ਜ� ਹਟਾ ਵੀ ਸਕਦੇ ਹ।ੋ 

ਨਤੀਜਾ: ਦਸਤਾਵੇਜ਼ ਿਵੱਚ ਿਚੱਤਰ ਅਤ ੇਟੇਬਲ ਵਰਤਣ ਨਾਲ ਸਮੱਗਰੀ ਹੋਰ ਵੀ ਿਦਲਚਸਪ, ਆਸਾਨੀ ਨਾਲ ਸਮਝਣ ਯੋਗ ਅਤ ੇ

ਿਵਅਵਸਿਥਤ ਬਣਦੀ ਹ।ੈ ਇਹ ਿਵ©ੇ© ਤੌਰ 'ਤੇ ਿਰਪਰੋਟ�, ਿਨਊਜ਼ਲੈਟਰ�, ਅਕਾਦਿਮਕ ਜ� ਿਬਜ਼ਨă {ਸ ਸਮੱਗਰੀ ਿਵੱਚ ਬਹੁਤ 

ਲਾਭਕਾਰੀ ਸਾਬਤ ਹੁੰ ਦ ੇਹਨ। 

 
Q. Explain the role of macros in MS-Word. Also explain various file formats and export features in it. 
(Nov 23) 
Ans. Macros in MS Word are used to automate repeƟƟve tasks. A macro is a recorded sequence of 
acƟons such as formaƫng, inserƟng text, or applying styles, which can be saved and replayed with a 
single click or shortcut key. This feature helps users save Ɵme and increase efficiency, especially in 
documents that require the same formaƫng or content repeatedly. To create a macro, go to View → 
Macros → Record Macro, perform the acƟons, and stop recording. The macro can then be reused 
anyƟme. 
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File Formats in MS Word determine how documents are saved and shared. Common formats include: 
 .docx – Default Word format, supports all features. 
 .doc – Older Word format, for compaƟbility with older versions. 
 .pdf – Portable Document Format, ideal for sharing and prinƟng. 
 .rƞ – Rich Text Format, preserves formaƫng and is compaƟble with many programs. 
 .txt – Plain text with no formaƫng. 
 .xml – Used for structured data storage. 

Export Features: Word allows exporƟng documents into different formats using File → Export. You can 
create PDFs, share documents, or change file types. These export opƟons ensure compaƟbility across 
devices, plaƞorms, and for professional prinƟng or digital publishing. 
ਮੈਕਰੋਜ਼ (Macros): MS Word ਿਵੱਚ ਮੈਕਰਜ਼ੋ ਦੀ ਵਰਤ� ਦੁਹਰਾਏ ਜ�ਦੇ ਕੰਮ� ਨੰੂ ਆਟੋਮਟੈ ਕਰਨ ਲਈ ਕੀਤੀ ਜ�ਦੀ ਹ।ੈ ਮੈਕਰ ੋ

ਇੱਕ ਐਕ©ਨ ਦੀ ਿਰਕਾਰਡ ਕੀਤੀ ਲੜੀ ਹੁੰ ਦੀ ਹ—ੈਿਜਵ� ਿਕ ਫਾਰਮਿੈਟੰਗ, ਟੈਕਸਟ ਇਨਸਰਟ ਕਰਨਾ ਜ� ਸਟਾਈਲ ਲਗਾਉਣਾ—

ਿਜਹਨੰੂ ਇੱਕ ਕਿਲੱਕ ਜ� ਸ਼ਾਰਟਕੱਟ ਕੀ ਨਾਲ ਦੁਬਾਰਾ ਚਲਾਇਆ ਜਾ ਸਕਦਾ ਹ।ੈ ਇਹ ਿਵ©ੇ©ਤਾਵ� ਸਮ� ਬਚਾਉਣ ਅਤ ੇਕੰਮ ਨੰੂ 

ਤੇਜ਼ ਬਣਾਉਣ ਿਵੱਚ ਮਦਦ ਕਰਦੀਆ ਂਹਨ, ਖਾਸ ਕਰਕ ੇਜਦ� ਤੁਸ� ਵਾਰ-ਵਾਰ ਇੱਕ ੋਿਜਹੀ ਫਾਰਮਿੈਟੰਗ ਜ� ਸਮੱਗਰੀ ਵਰਤਦੇ ਹ।ੋ 
ਮੈਕਰੋ ਬਣਾਉਣ ਦਾ ਤਰੀਕਾ: View → Macros → Record Macro 'ਤ ੇਜਾਓ, ਆਪਣੀ ਕਾਰਵਾਈ ਕਰ ੋਅਤ ੇਿਫਰ ਿਰਕਾਰਿਡੰਗ 

ਰੋਕ।ੋ ਇਹ ਮੈਕਰ ੋਬਾਅਦ ਿਵੱਚ ਿਕਸ ੇਵੀ ਸਮ� ਵਰਿਤਆ ਜਾ ਸਕਦਾ ਹ।ੈ 

 
ਫਾਈਲ ਫਾਰਮੈਟ (File Formats): MS Word ਿਵੱਚ ਦਸਤਾਵੇਜ਼ ਿਕਵ� ਸੰਭਾਲੇ ਜ� ਸ�ਝੇ ਕੀਤ ੇਜ�ਦੇ ਹਨ, ਇਹ ਫਾਈਲ ਫਾਰਮਟੈ 

�ਤੇ ਿਨਰਭਰ ਕਰਦਾ ਹ।ੈ 

ਆਮ Word ਫਾਈਲ ਫਾਰਮੈਟ: 

• .docx – ਿਡਫਾਲਟ Word ਫਾਰਮੈਟ, ਸਾਰ ੇਫੀਚਰ� ਨੰੂ ਸਿਹਯੋਗ ਿਦੰਦਾ ਹ।ੈ 

• .doc – ਪੁਰਾਣਾ ਫਾਰਮਟੈ, ਿਜਨ� � ਨੰੂ Word ਦ ੇਪੁਰਾਣੇ ਵਰਜਨ ਨਾਲ ਖੋਿਲ�ਆ ਜਾ ਸਕਦਾ ਹ।ੈ 

• .pdf – ਸ�ਝੇ ਕਰਨ ਅਤ ੇਿਪ�ੰ ਿਟੰਗ ਲਈ ਵਧੀਆ। 

• .rƞ – ਫਾਰਮਿੈਟੰਗ ਸਮੇਤ ਟੈਕਸਟ, ਬਹੁਤ ਸਾਰ ੇਐਪਲੀਕ©ੇਨ� ਨਾਲ ਕੰਪੈਿਟਬਲ। 

• .txt – ਸਧਾਰਨ ਟੈਕਸਟ, ਕਈੋ ਫਾਰਮਿੈਟੰਗ ਨਹ�। 

• .xml – ਸਟਰਕਚਰਡ ਡਾਟਾ ਸਟੋਰਜੇ ਲਈ ਵਰਿਤਆ ਜ�ਦਾ ਹ।ੈ 

 
ਐਕਸਪੋਰਟ ਿਵ©ੇ©ਤਾਵ� (Export Features): MS Word ਿਵੱਚ File → Export ਿਵਕਲਪ ਰਾਹ� ਤੁਸ� ਆਪਣਾ ਦਸਤਾਵੇਜ਼ 

ਵੱਖ-ਵੱਖ ਫਾਰਮਟੈ� ਿਵੱਚ ਐਕਸਪਰੋਟ ਕਰ ਸਕਦ ੇਹ।ੋ ਤੁਸ� PDF ਬਣਾਉਣ, ਦਸਤਾਵੇਜ਼ ਸ�ਝਾ ਕਰਨ ਜ� ਫਾਈਲ ਦਾ ਿਕਸਮ 

ਬਦਲਣ ਦੀ ਚਣੋ ਕਰ ਸਕਦੇ ਹ।ੋ ਇਹ ਿਵ©ੇ©ਤਾਵ� ਵੱਖ-ਵੱਖ ਿਡਵਾਈਸ�, ਪਲੇਟਫਾਰਮ� ਅਤ ੇਿਪ�ੰ ਿਟੰਗ ਜ� ਿਡਜ਼ੀਟਲ ਪਬਿਲਿ©ੰਗ 

ਲਈ ਕੰਪੈਿਟਿਬਿਲਟੀ ਨੰੂ ਯਕੀਨੀ ਬਣਾ�ਦੀਆ ਂਹਨ। 
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Unit-3: MS Excel (Nov 23),(Nov 19) 
Short Answer QuesƟons: 
 
Q. Discuss cell referencing in MS-Excel. (Nov 19)  
Ans. Cell referencing is the method of idenƟfying cells in formulas using names like A1 or B2. 
There are three types: relaƟve, absolute, and mixed referencing. 
ਸ{ੈਲ ਰੈਫਰ�ਿਸੰਗ ਉਹ ਢੰਗ ਹ ੈ ਿਜਸ ਰਾਹ� ਫਾਰਮਲੂ� ਿਵੱਚ ਸ{ੈਲ� ਨੰੂ A1 ਜ� B2 ਵਰਗੇ ਨਾਵ� ਨਾਲ ਪਛਾਿਣਆ ਜ�ਦਾ ਹ।ੈ 

ਇਸ ਦੀ ਿਤੰਨ ਿਕਸਮ� ਹੁੰ ਦੀਆ ਂਹਨ: ਿਰਲੇਿਟਵ (RelaƟve), ਐਬਸੋਿਲਊਟ (Absolute), ਅਤ ੇਿਮਕਸਡ (Mixed) ਰੈਫਰ�ਿਸੰਗ। 

 
Q. How cell protecƟon is performed in MS-Excel? (Nov 19) 
Ans. Cell protecƟon prevents accidental ediƟng or deleƟon of important data. 
It is enabled by locking cells and applying sheet protecƟon via the Review tab. 
ਸ{ੈਲ ਪ�ੋਟੈਕ©ਨ ਮਹੱਤਵਪਰੂਣ ਡਟੇਾ ਨੰੂ ਗਲਤੀ ਨਾਲ ਸੋਧਣ ਜ� ਿਮਟਾਉਣ ਤ� ਰੋਕਦੀ ਹ।ੈ 

ਇਹ ਸ{ੈਲ� ਨੰੂ ਲਾਕ ਕਰਕ ੇਅਤ ੇReview ਟਬੈ ਰਾਹ� ©ੀਟ ਪ�ੋਟੈਕ©ਨ ਲਾਗ ੂਕਰਕ ੇਚਾਲੂ ਕੀਤੀ ਜ�ਦੀ ਹ।ੈ 

 
Q. Menu Bars (Nov 23), (Nov 24) 
Ans. Menu bars in MS Office provide access to commands like File, Edit, View, and Insert. 
They organize features for easy navigaƟon and efficient document ediƟng. 
MS Office ਿਵੱਚ ਮੀਨੂ ਬਾਰ (Menu Bar) ਐਸ ੇਹੁਕਮ� ਤੱਕ ਪਹੁੰ ਚ ਪ�ਦਾਨ ਕਰਦੇ ਹਨ ਿਜਵ� ਿਕ File, Edit, View, ਅਤ ੇInsert। 
ਇਹ ਿਵ©ੇ©ਤਾਵ� ਨੰੂ ਢੰਗ ਨਾਲ ਿਵਭਾਜਤ ਕਰਕ ੇਆਸਾਨ ਨĂ ਵੀਗੇ©ਨ ਅਤ ੇਪ�ਭਾਵ©ਾਲੀ ਡੌਕਯੂਮ�ਟ ਐਿਡਿਟੰਗ ਯਕੀਨੀ ਬਣਾ�ਦ ੇ

ਹਨ। 

 
Q. PrinƟng operaƟon in MS-Excel (Nov 23) 
Ans. PrinƟng in Excel includes seƫng print area, adjusƟng layout, and using print preview. 
It ensures data fits well on paper with proper formaƫng. 
Excel ਿਵੱਚ ਛਾਪਾਈ (PrinƟng) ਿਵੱਚ ਿਪ�ੰ ਟ ਏਰੀਆ ਸੈ{ਟ ਕਰਨਾ, ਲੇਆਉਟ ਅਨੁਕੂਲ ਕਰਨਾ ਅਤ ੇਿਪ�ੰ ਟ ਪ�ੀਿਵਊ ਦੀ ਵਰਤ� 

ਕਰਨੀ ©ਾਮਲ ਹੁੰ ਦੀ ਹ।ੈ ਇਹ ਯਕੀਨੀ ਬਣਾ�ਦਾ ਹ ੈਿਕ ਡਾਟਾ ਸਹੀ ਫਾਰਮਟੈ ਿਵੱਚ ਕਾਗਜ਼ 'ਤ ੇਠੀਕ ਤਰੀਕ ੇਨਾਲ ਆਵੇ। 
 
Q. What is the importance of spreadsheet? (Nov 24) 
Ans. Spreadsheets help manage, calculate, and analyze large sets of data efficiently. 
They support formulas, charts, and data sorƟng for decision-making. 
ਸਪ�ੈਡ©ੀਟ ਵੱਡ ੇਡਾਟਾ ਸ{ੈਟ� ਨੰੂ ਪ�ਭਾਵ©ਾਲੀ ਢੰਗ ਨਾਲ ਪ�ਬੰਿਧਤ, ਗਣਨਾ ਅਤ ੇਿਵ©ਲੇ©ਣ ਕਰਨ ਿਵੱਚ ਮਦਦ ਕਰਦੀਆ ਂਹਨ। 

ਇਹ ਫਾਰਮੂਲੇ, ਚਾਰਟਸ ਅਤ ੇਡਾਟਾ ਸੋਰਿਟੰਗ ਨੰੂ ਸਮਰਥਨ ਿਦੰਦੀਆਂ ਹਨ, ਜੋ ਫੈਸਲਾ ਲੈਣ ਿਵੱਚ ਸਹਾਇਕ ਹੁੰ ਦ ੇਹਨ। 
 
Q. Write a short note on MS Access.  (Nov 24) 
Ans. MS Access is a database management tool for storing and managing structured data. 
It allows users to create tables, queries, forms, and reports easily. 
MS Access ਇੱਕ ਡੇਟਾਬੇਸ ਮੈਨĂ ਜਮ�ਟ ਟੂਲ ਹ ੈਜੋ ਠĄ ਸ (structured) ਡਾਟਾ ਨੰੂ ਸੰਭਾਲਣ ਅਤ ੇਪ�ਬੰਿਧਤ ਕਰਨ ਲਈ ਵਰਿਤਆ 

ਜ�ਦਾ ਹ।ੈ ਇਹ ਯੂਜ਼ਰ ਨੰੂ ਟੇਬਲ, ਕੁਏਰੀਜ਼, ਫਾਰਮਸ ਅਤ ੇਿਰਪੋਰਟਸ ਆਸਾਨੀ ਨਾਲ ਬਣਾਉਣ ਦੀ ਸਹਲੂਤ ਿਦੰਦਾ ਹ।ੈ 
 
Long Answer QuesƟons: 
Q. How you can create, open, save and quit a worksheet? Explain. (Nov 19) 
Ans. MicrosoŌ Excel is a spreadsheet applicaƟon used for data entry, calculaƟons, and analysis. 
Managing worksheets involves basic operaƟons like creaƟng, opening, saving, and quiƫng. 

1. CreaƟng a Worksheet: To create a new worksheet, open MS Excel and click File → New, then 
choose Blank Workbook. A new worksheet with default rows and columns will appear, ready for 
data entry. 
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2. Opening a Worksheet: To open an exisƟng worksheet, click File → Open, then browse and select 
the desired file from your computer, OneDrive, or recent files list. Excel supports various file 
formats like .xlsx, .xls, and .csv. 

3. Saving a Worksheet: Click File → Save or press Ctrl + S to save your work. For a new file, choose 
the locaƟon, enter a file name, and select the desired format (usually .xlsx). Use Save As to 
create a copy or change file type. 

4. Quiƫng Excel: To quit Excel, click File → Exit, or simply click the ‘X’ buƩon in the top-right corner. 
If there are unsaved changes, Excel will prompt you to save before closing. 

These steps help manage your work efficiently and ensure your data is stored safely for future use. 
MicrosoŌ Excel ਇੱਕ ਸਪ�ੈਡ©ੀਟ ਐਪਲੀਕ©ੇਨ ਹ ੈਜੋ ਡਾਟਾ ਐਟਂਰੀ, ਿਹਸਾਬ-ਿਕਤਾਬ ਅਤ ੇਿਵ©ਲੇ©ਣ ਲਈ ਵਰਤੀ ਜ�ਦੀ 

ਹ।ੈ ਵਰਕ©ੀਟ ਨੰੂ ਮੈਨĂ ਜ ਕਰਨਾ ਕੁਝ ਮੂਲ ਕੰਮ� 'ਤ ੇਆਧਾਰਤ ਹੁੰ ਦਾ ਹ,ੈ ਿਜਵ� ਿਕ ਬਣਾਉਣਾ, ਖਲੋ�ਣਾ, ਸੰਭਾਲਣਾ ਅਤ ੇਬੰਦ ਕਰਨਾ। 

1. ਵਰਕ©ੀਟ ਬਣਾਉਣਾ: ਨਵ� ਵਰਕ©ੀਟ ਬਣਾਉਣ ਲਈ MS Excel ਖੋਲ�ੋ  ਅਤ ੇFile → New → Blank Workbook ਤੇ ਕਿਲੱਕ 

ਕਰ।ੋ ਇੱਕ ਨਵ� ਵਰਕ©ੀਟ ਖੁਲ ਜਾਵੇਗੀ ਿਜਸ ਿਵੱਚ ਲਾਈਨ� ਅਤ ੇਕਾਲਮ ਹੋਣਗ,ੇ ਜੋ ਡਾਟਾ ਭਰਨ ਲਈ ਿਤਆਰ ਹੁੰ ਦੀ ਹ।ੈ 
2. ਵਰਕ©ੀਟ ਖੋਲ�ਣਾ: ਪੁਰਾਣੀ ਵਰਕ©ੀਟ ਖੋਲ�ਣ ਲਈ File → Open ਤੇ ਕਿਲੱਕ ਕਰ ੋਅਤ ੇਆਪਣੀ ਫਾਈਲ ਚੁਣ ੋ(.xlsx, .xls, 

.csv ਆਿਦ ਫਾਰਮਟੈ ਸਹਾਇਕ ਹਨ)। 

3. ਵਰਕ©ੀਟ ਸੰਭਾਲਣਾ: File → Save ਜ� Ctrl + S ਦਬਾ ਕ ੇਵਰਕ©ੀਟ ਨੰੂ ਸੰਭਾਲੋ। ਨਵ� ਫਾਈਲ ਲਈ ਸਥਾਨ, ਨਾਮ ਅਤ ੇ

ਫਾਰਮਟੈ (.xlsx ਆਮ ਤੌਰ 'ਤੇ) ਚਣੁ।ੋ Save As ਨਾਲ ਨਕਲ ਜ� ਨਵ� ਫਾਰਮਟੈ ਚੁਿਣਆ ਜਾ ਸਕਦਾ ਹ।ੈ 

4. Excel ਬੰਦ ਕਰਨਾ: Excel ਬੰਦ ਕਰਨ ਲਈ File → Exit ਜ� �ਪਰ ਵਾਲੇ 'X' ਬਟਨ ਤੇ ਕਿਲੱਕ ਕਰ।ੋ ਜੇਕਰ ਕੋਈ ਅਣਸੰਭਾਲੀ 

ਚੇਜ਼ ਹ,ੈ Excel ਤੁਹਾਨੰੂ ਸਵੇ ਕਰਨ ਲਈ ਪੁੱ ਛੇਗਾ। 

ਇਹ ਸਾਰ ੇਕਦਮ ਤੁਹਾਡੀ ਵਰਕ©ੀਟ ਨੰੂ ਢੰਗ ਨਾਲ ਮਨੈĂ ਜ ਕਰਨ ਅਤ ੇਡਾਟਾ ਨੰੂ ਸੁਰੱਿਖਅਤ ਰੱਖਣ ਿਵੱਚ ਮਦਦ ਕਰਦੇ ਹਨ। 
 
Q. Explain with examples how you can use formulas and funcƟons in MS excel. (Nov 19) 
Ans. MS Excel provides powerful tools like formulas and funcƟons to perform calculaƟons, analyze data, 
and automate tasks in spreadsheets. 
A formula in Excel is an expression used to calculate values. It always begins with an equals sign (=). For 
example, to add two numbers in cells A1 and B1, you can write: 
=A1 + B1 
This formula will display the sum of the two values. 
FuncƟons are predefined formulas that simplify complex calculaƟons. Excel includes a wide range of 
built-in funcƟons: 

 SUM(): Adds a range of numbers. Example: =SUM(A1:A5) adds values from cell A1 to A5. 
 AVERAGE(): Calculates the average of a range. Example: =AVERAGE(B1:B5) 
 IF(): Returns different values based on a condiƟon. Example: =IF(A1>50, "Pass", "Fail") 
 MAX() and MIN(): Returns the highest and lowest value. Example: =MAX(C1:C10) 
 COUNT(): Counts numeric entries in a range. Example: =COUNT(D1:D10) 

Formulas and funcƟons help automate tasks like payroll, budgeƟng, sales tracking, and academic 
performance analysis. By combining them, users can save Ɵme, reduce manual errors, and manage large 
data sets effecƟvely in Excel. 
MS Excel ਸ਼ਕਤੀ©ਾਲੀ ਟੂਲ� ਿਜਵ� ਿਕ ਫਾਰਮਲੇੂ ਅਤ ੇਫੰਕ©ਨ ਪ�ਦਾਨ ਕਰਦਾ ਹ,ੈ ਜੋ ਿਕ ਗਣਨਾਵ� ਕਰਨ, ਡਾਟਾ ਦਾ ਿਵ©ਲੇ©ਣ 

ਕਰਨ ਅਤ ੇਸਪ�ਡੈ©ੀਟ ਿਵੱਚ ਕੰਮ ਆਟੋਮਟੇ ਕਰਨ ਿਵੱਚ ਮਦਦ ਕਰਦੇ ਹਨ। 

ਫਾਰਮੂਲਾ Excel ਿਵੱਚ ਇੱਕ ਐਕਸਪ�ੈ©ਨ ਹੁੰ ਦਾ ਹ ੈਜੋ ਕੀਮਤ� ਦੀ ਗਣਨਾ ਕਰਨ ਲਈ ਵਰਿਤਆ ਜ�ਦਾ ਹ।ੈ ਇਹ ਹਮ©ੇਾ = ਿਨ©ਾਨ 

ਨਾਲ ©ੁਰ ੂਹੁੰ ਦਾ ਹ।ੈ ਉਦਾਹਰਨ ਵਜ�, ਜੇ ਤੁਸ� A1 ਅਤ ੇB1 ਸ{ੈਲ ਦੀਆ ਂਕੀਮਤ� ਜੋੜਣੀਆ ਂਹਨ, ਤ� ਤਸੁ� ਿਲਖ ਸਕਦੇ ਹ:ੋ 

=A1 + B1 
ਇਹ ਫਾਰਮਲੂਾ ਦਨੋ� ਸ{ੈਲ� ਦੀ ਜੋੜੀ ਹੋਈ ਕੀਮਤ ਿਦਖਾਏਗਾ। 
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ਫੰਕ©ਨ ਪਿਹਲ� ਤ� ਬਣੇ ਹੋਏ ਫਾਰਮੂਲੇ ਹੁੰ ਦ ੇਹਨ ਜੋ ਜਿਟਲ ਗਣਨਾਵ� ਨੰੂ ਆਸਾਨ ਬਣਾ�ਦੇ ਹਨ। Excel ਿਵੱਚ ਕਈ ਤਰ�� ਦੇ 

ਿਬਲਟ-ਇਨ ਫੰਕ©ਨ ਹੁੰ ਦ ੇਹਨ: 

• SUM(): ਨੰਬਰ� ਦੀ ਰ�ਜ ਜੋੜਦਾ ਹ।ੈ 

ਉਦਾਹਰਨ: =SUM(A1:A5) → A1 ਤ� A5 ਤੱਕ ਦੀਆ ਂਕੀਮਤ� ਜੋੜਦਾ ਹ।ੈ 

• AVERAGE(): ਰ�ਜ ਦੀ ਔਸਤ ਕੱਢਦਾ ਹ।ੈ 
ਉਦਾਹਰਨ: =AVERAGE(B1:B5) 

• IF(): ©ਰਤ ਅਨੁਸਾਰ ਵੱਖ-ਵੱਖ ਕੀਮਤ� ਿਦੰਦਾ ਹ।ੈ 
ਉਦਾਹਰਨ: =IF(A1>50, "Pass", "Fail") 

• MAX() ਅਤ ੇMIN(): ਸਭ ਤ� ਵੱਡੀ ਜ� ਛੋਟੀ ਕੀਮਤ ਿਲਆ�ਦ ੇਹਨ। 
ਉਦਾਹਰਨ: =MAX(C1:C10) 

• COUNT(): ਿਦੱਤੀ ਰ�ਜ ਿਵੱਚ ਨੰਬਰ ਵਾਲੀਆਂ ਐਟਂਰੀਆ ਂਦੀ ਿਗਣਤੀ ਕਰਦਾ ਹ।ੈ 
ਉਦਾਹਰਨ: =COUNT(D1:D10) 

ਨਤੀਜਾ: ਫਾਰਮਲੇੂ ਅਤ ੇਫੰਕ©ਨ ਪੇਰਲੋ, ਬਜਿਟੰਗ, ਿਵਕਰੀ ਦੀ ਟਰੈਿਕੰਗ, ਅਤ ੇਅਕਾਦਿਮਕ ਿਵ©ਲੇ©ਣ ਵਰਗੇ ਕੰਮ ਆਸਾਨੀ 

ਨਾਲ ਕਰਨ ਲਈ ਵਰਤ ੇਜ�ਦੇ ਹਨ। ਇਹ ਨਾਲ ਨ� ਿਸਰਫ ਸਮ� ਬਚਦਾ ਹ,ੈ ਸਗ� ਹੱਥ� ਹੋਣ ਵਾਲੀਆਂ ਗਲਤੀਆਂ ਵੀ ਘੱਟ ਹੁੰ ਦੀਆ ਂ

ਹਨ, ਅਤ ੇਵੱਡੇ ਡਾਟਾ ਸ{ੈਟ ਆਸਾਨੀ ਨਾਲ ਮੈਨĂ ਜ ਕੀਤੇ ਜ�ਦੇ ਹਨ। 

 
Q. What is the importance of MS Excel? Write a short note on inserƟng the data in Excel. (Nov 24) 
Ans. MicrosoŌ Excel is one of the most powerful and widely used spreadsheet applicaƟons. It is essenƟal 
for organizing, analyzing, and visualizing data. Excel is used in various fields such as business, educaƟon, 
accounƟng, data analysis, and research due to its flexibility and rich set of features. 
The importance of MS Excel lies in its ability to handle large amounts of data efficiently. It allows users 
to perform complex calculaƟons using formulas and funcƟons, create charts and graphs for data 
visualizaƟon, and generate reports. Excel also supports data sorƟng, filtering, condiƟonal formaƫng, 
and pivot tables, which help in beƩer decision-making and producƟvity. 
InserƟng Data in Excel: 
InserƟng data in Excel is simple and user-friendly. To enter data: 

1. Click on a cell (like A1) where you want to enter the value. 
2. Type text, numbers, or formulas directly into the cell. 
3. Press Enter to move to the cell below or Tab to move to the next cell on the right. 

Excel automaƟcally formats numbers, dates, and text as you enter them. You can also copy-paste data 
from other sources or use Data → From Text/CSV to import data from external files. Proper data entry 
is the first step to effecƟve analysis and presentaƟon. 
ਮਾਈਕ�ੋਸਾਫਟ ਐਕਸਲ ਸਭ ਤ� ©ਕਤੀ©ਾਲੀ ਅਤ ੇਿਵਆਪਕ ਤੌਰ 'ਤ ੇਵਰਤੀ ਜਾਣ ਵਾਲੀਆ ਂਸਪ�ੈਡ©ੀਟ ਐਪਲੀਕ©ੇਨ� ਿਵੱਚ� ਇੱਕ 

ਹ।ੈ ਇਹ ਡਾਟਾ ਨੰੂ ਿਵਵਸਿਥਤ, ਿਵ©ਲੇ©ਣ ਅਤ ੇਿਵਜ਼ੂਅਲਾਈਜ਼ ਕਰਨ ਲਈ ਬਹੁਤ ਹੀ ਲਾਭਕਾਰੀ ਹ।ੈ ਐਕਸਲ ਵਪਾਰ, ਿਸੱਿਖਆ, 

ਲੇਖਾਕਾਰੀ, ਡਾਟਾ ਿਵ©ਲੇ©ਣ ਅਤ ੇ ਿਰਸਰਚ ਵਰਗੇ ਕਈ ਖਤੇਰ� ਿਵੱਚ ਵਰਿਤਆ ਜ�ਦਾ ਹ ੈ ਿਕ�ਿਕ ਇਹ ਲਚਕੀਲਾ ਹ ੈਅਤ ੇ

ਿਵ©ੇ©ਤਾਵ� ਨਾਲ ਭਰਪਰੂ ਹ।ੈ 
MS Excel ਦੀ ਮਹੱਤਤਾ ਇਸ ਦੀ ਸਮਰੱਥਾ ਿਵੱਚ ਹ ੈਿਕ ਇਹ ਵੱਡੀ ਮਾਤਰਾ ਿਵੱਚ ਡਾਟਾ ਨੰੂ ਪ�ਭਾਵ©ਾਲੀ ਢੰਗ ਨਾਲ ਹ�ਡਲ ਕਰ 

ਸਕਦਾ ਹ।ੈ ਇਹ ਉਪਭੋਗਤਾਵ� ਨੰੂ ਫਾਰਮਿੂਲਆ ਂਅਤ ੇਫੰਕ©ਨ� ਦੀ ਵਰਤ� ਕਰਕ ੇਜਿਟਲ ਗਣਨਾਵ� ਕਰਨ, ਡਾਟਾ ਦੀ ਿਵਜ਼ੂਅਲ 

ਪ�ਸਤੁਤੀ ਲਈ ਚਾਰਟ ਅਤ ੇਗ�ਾਫ ਬਣਾਉਣ ਅਤ ੇ ਿਰਪਰੋਟ� ਿਤਆਰ ਕਰਨ ਦੀ ਆਿਗਆ ਿਦੰਦਾ ਹ।ੈ Excel ਿਵੱਚ ਡਾਟਾ ਸੋਰਟ 

ਕਰਨਾ, ਿਫਲਟਰ ਲਗਾਉਣਾ, ਕਡਂੀ©ਨਲ ਫਾਰਮਿੈਟੰਗ ਅਤ ੇਿਪਵਟ ਟੇਬਲ ਵਰਗੀਆ ਂਿਵ©ੇ©ਤਾਵ� ਵੀ ਹਨ ਜੋ ਫੈਸਲੇ ਲੈਣ ਅਤ ੇ

ਉਤਪਾਦਕਤਾ ਵਧਾਉਣ ਿਵੱਚ ਮਦਦ ਕਰਦੀਆਂ ਹਨ। 
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Excel ਿਵੱਚ ਡਾਟਾ ਇਨਸਰਟ ਕਰਨਾ: 

Excel ਿਵੱਚ ਡਾਟਾ ਦਾਖਲ ਕਰਨਾ ਬਹੁਤ ਹੀ ਆਸਾਨ ਅਤ ੇਯੂਜ਼ਰ-ਫ��ਡਲੀ ਹੁੰ ਦਾ ਹ।ੈ 

1. ਉਸ ਸ{ੈਲ �ਤੇ ਕਿਲਕ ਕਰ ੋ(ਿਜਵ� A1) ਿਜੱਥ ੇਤੁਸ� ਕੀਮਤ ਦਾਖਲ ਕਰਨੀ ਹ।ੈ 

2. ਸ{ੈਲ ਿਵੱਚ ਟੈਕਸਟ, ਨੰਬਰ ਜ� ਫਾਰਮੂਲਾ ਿਲਖ।ੋ 

3. Enter ਦਬਾਉਣ ਨਾਲ ਅਗਲੇ ਸ{ੈਲ 'ਤ ੇਜਾਇਆ ਜ�ਦਾ ਹ,ੈ ਜ� Tab ਨਾਲ ਸੱਜ ੇਪਾਸ ੇਸ{ੈਲ 'ਤੇ। 

Excel ਆਪਣੇ ਆਪ ਹੀ ਨੰਬਰ, ਿਮਤੀਆ ਂਅਤ ੇਟੈਕਸਟ ਨੰੂ ਫਾਰਮਟੈ ਕਰ ਲ�ਦਾ ਹ।ੈ ਤੁਸ� ਬਾਹਰੀ ਸਤੋਰ� ਤ� ਡਾਟਾ ਕਾਪੀ-ਪੇਸਟ ਵੀ 

ਕਰ ਸਕਦ ੇਹ ੋਜ� Data → From Text/CSV ਦੀ ਵਰਤ� ਕਰਕ ੇਡਾਟਾ ਇੰਪੋਰਟ ਕਰ ਸਕਦ ੇਹ।ੋ 

ਸਹੀ ਢੰਗ ਨਾਲ ਡਾਟਾ ਇਨਸਰਟ ਕਰਨਾ ਡਾਟਾ ਿਵ©ਲੇ©ਣ ਅਤ ੇਪ�ਸਤੁਤੀ ਦੀ ਪਿਹਲੀ ਅਤ ੇਸਭ ਤ� ਜ਼ਰੂਰੀ ਕਦਮ ਹੁੰ ਦੀ ਹ।ੈ 

 
Q. Briefly explain the steps of showing slides with graphs and animaƟon. (Nov 24) 
Ans. MicrosoŌ PowerPoint allows users to create visually appealing presentaƟons by inserƟng graphs 
and applying animaƟons to slides. These features help convey data and ideas more effecƟvely and keep 
the audience engaged. 
Steps to Insert Graphs: 

1. Open PowerPoint and go to the slide where you want to insert the graph. 
2. Click on the Insert tab → Select Chart. 
3. Choose the desired chart type (Column, Line, Pie, etc.) from the dialog box. 
4. A sample chart and a linked Excel sheet will appear. Enter or edit the data in the sheet. 
5. Close the Excel sheet to update the chart on the slide. 
6. Use Chart Tools (Design & Format tabs) to customize the appearance of the graph. 

Steps to Add AnimaƟon: 
1. Select the text, image, or chart you want to animate. 
2. Go to the AnimaƟons tab. 
3. Choose an animaƟon effect (e.g., Fade, Fly In, Zoom) from the AnimaƟon gallery. 
4. Use AnimaƟon Pane to adjust the order and Ɵming of animaƟons. 
5. You can also apply Entrance, Emphasis, Exit, or MoƟon Path effects. 

Finally, use the Slide Show tab to preview or run your animated presentaƟon. These tools make 
presentaƟons more dynamic and informaƟve. 
ਮਾਈਕ�ੋਸਾਫਟ ਪਾਵਰਪਇੰੌਟ ਉਪਭੋਗਤਾਵ� ਨੰੂ ਆਕਰ©ਕ ਪ�ਜ਼�ਟੇ©ਨ ਬਣਾਉਣ ਦੀ ਸਹਲੂਤ ਿਦੰਦਾ ਹ ੈ ਿਜਸ ਿਵੱਚ ਗ�ਾਫ ©ਾਮਲ 

ਕਰਕ ੇਅਤ ੇਸਲਾਈਡ� �ਤ ੇਐਨੀਮ©ੇਨ ਲਗਾ ਕ ੇਜਾਣਕਾਰੀ ਨੰੂ ਪ�ਭਾਵ©ਾਲੀ ਢੰਗ ਨਾਲ ਪ©ੇ ਕੀਤਾ ਜਾ ਸਕਦਾ ਹ।ੈ ਇਹ ਿਵ©ੇ©ਤਾਵ� 

ਡਾਟਾ ਅਤ ੇਿਵਚਾਰ� ਨੰੂ ਆਸਾਨੀ ਨਾਲ ਸਮਝਾਉਣ ਿਵੱਚ ਮਦਦ ਕਰਦੀਆ ਂਹਨ ਅਤ ੇਦਰ©ਕ� ਦੀ ਿਧਆਨ ਕ�ਦਿਰਤ ਰੱਖਦੀਆ ਂ

ਹਨ। 

 :ਗ�ਾਫ ਇਨਸਰਟ ਕਰਨ ਦ ੇਕਦਮ ݘݗݖݕݔݓ 

1. PowerPoint ਖੋਲ�ੋ  ਅਤ ੇਉਹ ਸਲਾਈਡ ਚਣੁ ੋਿਜੱਥ ੇਤੁਸ� ਗ�ਾਫ ਲਗਾਉਣਾ ਚਾਹੁੰ ਦ ੇਹ।ੋ 

2. Insert ਟੈਬ 'ਤੇ ਜਾਓ → Chart ਚੁਣੋ। 

3. ਡਾਇਲਾਗ ਬਾਕਸ ਿਵੱਚ� ਚਾਹੀਦਾ ਚਾਰਟ ਿਕਸਮ (ਿਜਵ� Column, Line, Pie ਆਿਦ) ਚੁਣੋ। 

4. ਇੱਕ ਨਮਨੂਾ ਚਾਰਟ ਅਤ ੇExcel ©ੀਟ ਖੁਲ�ੇਗੀ। Excel ਿਵੱਚ ਡਾਟਾ ਦਾਖਲ ਜ� ਸੰਪਾਿਦਤ ਕਰ।ੋ 

5. Excel ©ੀਟ ਬੰਦ ਕਰ ੋਤ� ਜੋ ਗ�ਾਫ ਸਲਾਈਡ �ਤੇ ਅੱਪਡੇਟ ਹ ੋਜਾਵੇ। 

6. Chart Tools (Design ਅਤ ੇFormat) ਦੀ ਵਰਤ� ਕਰਕ ੇਗ�ਾਫ ਦੀ ਰੂਪ-ਰ◌ખે◌ਾ ਸੋਧ।ੋ 

 ႱႲႳႴ ਐਨੀਮੇ©ਨ ਲਗਾਉਣ ਦ ੇਕਦਮ: 

1. ਉਸ ਟੈਕਸਟ, ਿਚੱਤਰ ਜ� ਚਾਰਟ ਨੰੂ ਚਣੁ ੋਿਜਸ �ਤੇ ਐਨੀਮ©ੇਨ ਲਗਾਉਣੀ ਹ।ੈ 

2. AnimaƟons ਟਬੈ 'ਤੇ ਜਾਓ। 
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3. AnimaƟon Gallery ਿਵੱਚ� Fade, Fly In, Zoom ਆਿਦ ਵਰਗਾ ਕਈੋ effect ਚਣੁ।ੋ 

4. AnimaƟon Pane ਦੀ ਵਰਤ� ਕਰਕ ੇਐਨੀਮ©ੇਨ ਦੇ ਆਰਡਰ ਅਤ ੇਸਮ� ਬਦਲੋ। 

5. ਤੁਸ� Entrance, Emphasis, Exit ਜ� MoƟon Path ਵਰਗੇ ਵੱਖ-ਵੱਖ effects ਵੀ ਲਗਾ ਸਕਦ ੇਹ।ੋ 

ਅੰਤ ਿਵੱਚ, Slide Show ਟਬੈ ਦੀ ਵਰਤ� ਕਰਕ ੇਆਪਣੀ ਐਨੀਮੇਿਟਡ ਪ�ਜ਼�ਟੇ©ਨ ਨੰੂ ਪ�ੀਿਵਊ ਜ� ਚਲਾਇਆ ਜਾ ਸਕਦਾ ਹ।ੈ 

ਇਹ ਸਾਰ ੇਟਲੂ PowerPoint ਪ�ਜ਼�ਟੇ©ਨ� ਨੰੂ ਹੋਰ ਵੀ ਿਦਲਚਸਪ, ਸੰਵੇਦਨ©ੀਲ ਅਤ ੇਜਾਣਕਾਰੀਭਰਪੂਰ ਬਣਾ�ਦ ੇਹਨ। 
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Unit-4: MS PowerPoint 
Short Answer QuesƟons: 
 
Q. How a chart is added to a slide? (Nov 19) 
Ans. In PowerPoint, a chart can be inserted using "Insert → Chart" opƟon. 
It helps visually represent data within a slide for beƩer understanding. 
PowerPoint ਿਵੱਚ, ਚਾਰਟ "Insert → Chart" ਿਵਕਲਪ ਦੀ ਵਰਤ� ਕਰਕ ੇ ਇਨਸਰਟ ਕੀਤਾ ਜਾ ਸਕਦਾ ਹ।ੈ 

ਇਹ ਡਾਟਾ ਨੰੂ ਿਵਜ਼ੂਅਲ ਰੂਪ ਿਵੱਚ ਦਰਸਾ�ਦਾ ਹ,ੈ ਿਜਸ ਨਾਲ ਜਾਣਕਾਰੀ ਨੰੂ ਸਮਝਣਾ ਅਸਾਨ ਹੁੰ ਦਾ ਹ।ੈ 
 
Q. What are file formats? (Nov 24) 
Ans. File formats define how data is stored in a file, like .docx, .xlsx, .pptx. 
Different formats are used for compaƟbility and specific applicaƟons. 
ਫ਼ਾਈਲ ਫਾਰਮਟੈ ਇਹ ਦਰਸਾ�ਦੇ ਹਨ ਿਕ ਡਾਟਾ ਫ਼ਾਈਲ ਿਵੱਚ ਿਕਵ� ਸੰਭਾਿਲਆ ਜ�ਦਾ ਹ,ੈ ਿਜਵ� ਿਕ .docx, .xlsx, .pptx। 

ਵੱਖ-ਵੱਖ ਫਾਰਮਟੈਸ ਨੰੂ ਅਨੁਕੂਲਤਾ ਅਤ ੇਖਾਸ ਐਪਲੀਕ©ੇਨ� ਲਈ ਵਰਿਤਆ ਜ�ਦਾ ਹ।ੈ 
 
Q. What is the benefit of Power point? (Nov 24) 
Ans. PowerPoint helps create engaging presentaƟons using slides, text, images, and animaƟons.It is 
widely used for educaƟon, business, and communicaƟon. 
ਪਾਵਰਪਇੰੌਟ ਸਲਾਈਡ�, ਿਲਖਤ, ਿਚੱਤਰ� ਅਤ ੇਐਨੀਮ©ੇਨ� ਦੀ ਵਰਤ� ਕਰਕ ੇਿਦਲਚਸਪ ਪ�ਜ਼�ਟੇ©ਨ ਿਤਆਰ ਕਰਨ ਿਵੱਚ ਮਦਦ 

ਕਰਦਾ ਹ।ੈਇਹ ਿਵਿਦਆ, ਕਾਰਬੋਾਰ ਅਤ ੇਸੰਚਾਰ ਲਈ ਿਵਅਪਕ ਤੌਰ 'ਤੇ ਵਰਿਤਆ ਜ�ਦਾ ਹ।ੈ 
 
Q. Spell checking in MS-Word  (Nov 23) 
Ans. MS Word automaƟcally checks spelling errors and underlines them in red. 
You can correct errors using the “Spelling & Grammar” tool under the Review tab. 
ਐਮਐਸ ਵਰਡ ਆਪਣੇ ਆਪ ਹੀ ©ਬਦ� ਦੀ ਗਲਤੀਆ ਂਜ�ਚਦਾ ਹ ੈਅਤ ੇਗਲਤ ©ਬਦ� ਨੰੂ ਲਾਲ ਰੇਖਾ ਨਾਲ ਰੇਿਖਤ ਕਰਦਾ ਹ।ੈ 
ਤੁਸ� "Review" ਟਬੈ ਹੇਠ� ਆਉਣ ਵਾਲੇ “Spelling & Grammar” ਟੂਲ ਦੀ ਵਰਤ� ਕਰਕ ੇਇਨ� � ਗਲਤੀਆ ਂਨੰੂ ਠੀਕ ਕਰ ਸਕਦ ੇ

ਹ।ੋ 

 
Q. Discuss formaƫng of text in MS-Office. (Nov 19) 
Ans. Text formaƫng includes changing font style, size, color, and applying bold, italics, or underline. It 
improves the readability and appearance of documents. 
ਟੈਕਸਟ ਫਾਰਮਿੈਟੰਗ ਿਵੱਚ ਫ�ਟ ਦੀ ©ੈਲੀ, ਆਕਾਰ, ਰੰਗ ਬਦਲਣਾ ਅਤ ੇbold, italics ਜ� underline ਲਾਗ ੂਕਰਨਾ ©ਾਮਲ ਹੁੰ ਦਾ 

ਹ।ੈ ਇਹ ਦਸਤਾਵੇਜ਼� ਦੀ ਪੜ�ਨਯਗੋਤਾ ਅਤ ੇਿਦੱਖ ਿਵੱਚ ਸੁਧਾਰ ਕਰਦਾ ਹ।ੈ 

 
Q. Discuss spell-check feature of MS-Office. (Nov 19) 
Ans. The spell-check tool highlights incorrect words and suggests correcƟons. 
It ensures error-free wriƟng in documents, spreadsheets, and presentaƟons.  
ਸਪਲੈ-ਚ{ੈਕ ਟਲੂ ਗਲਤ ©ਬਦ� ਨੰੂ ਹਾਈਲਾਈਟ ਕਰਦਾ ਹ ੈ ਅਤ ੇ ਸਹੀ ©ਬਦ� ਦੀ ਿਸਫਾਰ© ਕਰਦਾ ਹ।ੈ 

ਇਹ ਦਸਤਾਵੇਜ਼�, ਸਪ�ੈ{ਡ©ੀਟ� ਅਤ ੇਪ�ਜ਼�ਟੇ©ਨ� ਿਵੱਚ ਗਲਤੀ-ਰਿਹਤ ਿਲਖਤ ਨੰੂ ਯਕੀਨੀ ਬਣਾ�ਦਾ ਹ।ੈ 

  
Long Answer QuesƟons: 
Q. What do you mean by slide-show? What opƟons are available for this? (Nov 19) 
Ans. A slide show in MicrosoŌ PowerPoint is a presentaƟon mode that displays slides one by one in full-
screen view. It is used to present informaƟon visually and interacƟvely during meeƟngs, lectures, or 
events. A slide show typically includes text, images, charts, animaƟons, and transiƟons to engage the 
audience and communicate ideas effecƟvely. 
StarƟng a Slide Show: 
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To begin a slide show, go to the Slide Show tab and choose from the following opƟons: 
1. From Beginning: Starts the slide show from the first slide. 
2. From Current Slide: Begins the presentaƟon from the slide you are currently working on. 
3. Custom Slide Show: Allows you to create a custom sequence of selected slides. 

Slide Show OpƟons: 
 Set Up Slide Show: Customize how the presentaƟon is displayed (e.g., full screen, windowed, or 

looped). 
 Use Timings: AutomaƟcally advance slides based on preset Ɵmings. 
 Record Slide Show: Record narraƟon, slide Ɵmings, and pointer movements for later playback. 
 Rehearse Timings: PracƟce the presentaƟon and set slide duraƟons. 
 Presenter View: Shows notes and upcoming slides on the presenter’s screen while the audience 

sees only the current slide. 
These features make PowerPoint presentaƟons more flexible, interacƟve, and professional. 
ਮਾਈਕ�ੋਸਾਫਟ ਪਾਵਰਪਇੰੌਟ ਿਵੱਚ ਸਲਾਈਡ ©ੋ ਇੱਕ ਪ�ਜ਼�ਟੇ©ਨ ਮੋਡ ਹੁੰ ਦਾ ਹ ੈਜੋ ਸਲਾਈਡ� ਨੰੂ ਇੱਕ-ਇੱਕ ਕਰਕ ੇਫੁੱ ਲ ਸਕ�ੀਨ ਿਵਚ 

ਿਵਖਾ�ਦਾ ਹ।ੈ ਇਹ ਬੈਠਕ�, ਲੈਕਚਰ� ਜ� ਸਮਾਰੋਹ� ਦੌਰਾਨ ਜਾਣਕਾਰੀ ਨੰੂ ਿਵਜ਼ੂਅਲ ਅਤ ੇਇੰਟਰਐਕਿਟਵ ਢੰਗ ਨਾਲ ਪ©ੇ ਕਰਨ 

ਲਈ ਵਰਿਤਆ ਜ�ਦਾ ਹ।ੈ ਸਲਾਈਡ ©ੋ ਿਵੱਚ ਆਮ ਤੌਰ 'ਤੇ ਟੈਕਸਟ, ਿਚੱਤਰ, ਚਾਰਟ, ਐਨੀਮ©ੇਨ ਅਤ ੇਟ��ਜ਼ੀ©ਨ ©ਾਮਲ ਹੁੰ ਦੇ 

ਹਨ, ਜੋ ਦਰ©ਕ� ਨੰੂ ਆਕਰਿ©ਤ ਕਰਨ ਅਤ ੇਿਵਚਾਰ� ਨੰੂ ਪ�ਭਾਵ©ਾਲੀ ਢੰਗ ਨਾਲ ਪਹੁੰ ਚਾਉਣ ਿਵੱਚ ਮਦਦ ਕਰਦੇ ਹਨ। 
ਸਲਾਈਡ ©ੋ ©ੁਰੂ ਕਰਨ ਦ ੇਤਰੀਕ:ੇ 

Slide Show ਟਬੈ 'ਤੇ ਜਾਓ ਅਤ ੇਹੇਠ� ਿਦੱਤ ੇਿਵਕਲਪ� ਿਵੱਚ� ਚਣੁ:ੋ 

1. From Beginning – ਸਲਾਈਡ ©ੋ ਪਿਹਲੀ ਸਲਾਈਡ ਤ� ©ੁਰ ੂਕਰਦਾ ਹ।ੈ 

2. From Current Slide – ਮੌਜੂਦਾ ਸਲਾਈਡ ਤ� ਪ�ਜ਼�ਟੇ©ਨ ©ੁਰ ੂਕਰਦਾ ਹ।ੈ 

3. Custom Slide Show – ਚਣੁੀਆ ਂਸਲਾਈਡ� ਦੀ ਇੱਕ ਿਵ©ੇ© ਕ�ਮਵਾਰਤਾ ਬਣਾਉਣ ਦੀ ਸਹਲੂਤ ਿਦੰਦਾ ਹ।ੈ 

ਸਲਾਈਡ ©ੋ ਦ ੇਿਵਕਲਪ: 

 Set Up Slide Show – ਪ�ਜ਼�ਟੇ©ਨ ਨੰੂ ਿਕਵ� ਿਵਖਾਇਆ ਜਾਵੇ (ਿਜਵ� ਿਕ ਫੁੱ ਲ ਸਕ�ੀਨ, ਿਵੰਡੋ, ਜ� ਲੂਪ) ਕਸਟਮਾਈਜ਼ 

ਕਰ।ੋ 

 Use Timings – ਸਲਾਈਡ� ਨੰੂ ਆਪਣੇ-ਆਪ ਅਗ ੇਵਧਾਉਣ ਲਈ ਸਮ� ਸ{ੈਟ ਕਰ।ੋ 

 Record Slide Show – ਆਵਾਜ਼, ਟਾਈਿਮੰਗ ਅਤ ੇਮਾਊਸ ਮਵੂਮ�ਟ ਿਰਕਾਰਡ ਕਰ।ੋ 

 Rehearse Timings – ਅਿਭਆਸ ਕਰਕ ੇਸਲਾਈਡ� ਲਈ ਸਮ� ਿਨਰਧਾਿਰਤ ਕਰ।ੋ 

 Presenter View – ਪ�ਜ਼�ਟਰ ਨੰੂ ਨĄ ਟਸ ਅਤ ੇਅਗਲੀ ਸਲਾਈਡ ਿਦਖਾਈ ਜ�ਦੀ ਹ,ੈ ਜਦਿਕ ਦਰ©ਕ ਿਸਰਫ ਮੌਜੂਦਾ 

ਸਲਾਈਡ ਵੇਖਦ ੇਹਨ। 

ਇਹ ਿਵ©ੇ©ਤਾਵ� PowerPoint ਪ�ਜ਼�ਟੇ©ਨ� ਨੰੂ ਹੋਰ ਲਚਕੀਲਾ, ਇੰਟਰਐਕਿਟਵ ਅਤ ੇਪ©ੇਾਵਰ ਬਣਾ�ਦੀਆ ਂਹਨ। 
 
Q. Discuss the steps involved in creaƟng and ediƟng power point presentaƟons. (Nov 23) 
Ans. CreaƟng and ediƟng a PowerPoint presentaƟon involves several simple steps that help in 
developing a structured, engaging, and professional slideshow. 
Steps to Create a PresentaƟon: 

1. Open PowerPoint: Start the applicaƟon and select Blank PresentaƟon or choose a template 
from available themes. 

2. Insert Title Slide: Enter the presentaƟon Ɵtle and subƟtle on the first slide. 
3. Add New Slides: Go to the Home tab → Click New Slide to insert more slides. Choose different 

layouts (Title and Content, Two Content, Comparison, etc.) as needed. 
4. Add Content: Click on text boxes to type or paste content. Use Insert tab to add images, charts, 

tables, shapes, and SmartArt. 
5. Apply Design: Choose a design theme from the Design tab to give your slides a consistent look. 

Steps to Edit a PresentaƟon: 
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1. Format Text and Objects: Use Font, Paragraph, and Arrange opƟons to adjust appearance and 
layout. 

2. Apply AnimaƟons and TransiƟons: Use AnimaƟons and TransiƟons tabs to add movement 
between or within slides. 

3. Review and Proofread: Check spelling and slide sequence. 
4. Save and Present: Click File → Save, then use the Slide Show tab to rehearse or present. 

These steps help create effecƟve, polished presentaƟons for any audience. 
ਪਾਵਰਪਇੰੌਟ ਪ�ਜ਼�ਟੇ©ਨ ਬਣਾਉਣ ਅਤ ੇਸੰਪਾਦਨ ਕਰਨ ਦੇ ਕਈ ਆਸਾਨ ਕਦਮ ਹੁੰ ਦੇ ਹਨ, ਜੋ ਤੁਹਾਨੰੂ ਇੱਕ ਢ�ਚਾਬੱਧ, ਿਦਲਚਸਪ 

ਅਤ ੇਪ©ੇਾਵਰ ਸਲਾਈਡ ©ੋ ਿਤਆਰ ਕਰਨ ਿਵੱਚ ਮਦਦ ਕਰਦ ੇਹਨ। 

ਪ�ਜ਼�ਟ©ੇਨ ਬਣਾਉਣ ਦ ੇਕਦਮ: 

1. PowerPoint ਖਲੋ�ੋ: ਐਪਲੀਕ©ੇਨ ©ੁਰ ੂਕਰ ੋਅਤ ੇBlank PresentaƟon ਜ� ਕਈੋ ਮੌਜੂਦਾ ਥੀਮ ਚਣੁ।ੋ 

2. Title Slide ©ਾਮਲ ਕਰੋ: ਪਿਹਲੀ ਸਲਾਈਡ 'ਤੇ ਪ�ਜ਼�ਟੇ©ਨ ਦਾ ਿਸਰਲੇਖ ਅਤ ੇਉਪਿਸਰਲੇਖ ਿਲਖ।ੋ 

3. ਨਵੀਆਂ ਸਲਾਈਡ� ਜੜੋੋ: Home ਟੈਬ 'ਤੇ ਜਾਓ → New Slide 'ਤ ੇਕਿਲੱਕ ਕਰ।ੋ ਲੋੜ ਅਨੁਸਾਰ ਵੱਖ-ਵੱਖ ਲੇਆਉਟ 

(Title and Content, Comparison ਆਿਦ) ਚਣੁ।ੋ 

4. ਸਮੱਗਰੀ ©ਾਮਲ ਕਰੋ: ਟੈਕਸਟ ਬਾਕਸ 'ਚ ਟਾਈਪ ਕਰ ੋਜ� ਪੇਸਟ ਕਰ।ੋ Insert ਟੈਬ ਤ� ਿਚੱਤਰ, ਚਾਰਟ, ਟੇਬਲ, ©ੇਪ 

ਅਤ ੇSmartArt ਜੋੜ।ੋ 

5. ਿਡਜ਼ਾਈਨ ਲਗਾਓ: Design ਟੈਬ ਤ� ਥੀਮ ਚਣੁ,ੋ ਜੋ ਸਾਰੀਆਂ ਸਲਾਈਡ� ਲਈ ਇੱਕ ੋਿਜਹੀ ਲੁੱ ਕ ਿਦੰਦੀ ਹ।ੈ 

ਪ�ਜ਼�ਟ©ੇਨ ਨੰੂ ਸੰਪਾਿਦਤ ਕਰਨ ਦ ੇਕਦਮ: 

1. ਟੈਕਸਟ ਅਤ ੇਆਬਜੈਕਟ ਫਾਰਮਟੈ ਕਰੋ: Font, Paragraph ਅਤ ੇArrange ਿਵਕਲਪ� ਦੀ ਵਰਤ� ਕਰਕ ੇਿਦੱਖ ਅਤ ੇ

ਲੇਆਉਟ ਸੋਧ।ੋ 

2. ਐਨੀਮੇ©ਨ ਅਤ ੇਟ��ਜ਼ੀ©ਨ ਲਗਾਓ: AnimaƟons ਅਤ ੇTransiƟons ਟੈਬ ਤ� ਚਲਣ ਵਾਲੇ ਅਸਰ ਜੋੜ।ੋ 

3. ਸਮੀਿਖਆ ਅਤ ੇਸ�ਝਾ ਕਰਨਾ: ਗਲਤੀਆਂ ਜ� ਸਲਾਈਡ ਕ�ਮ ਦੀ ਜ�ਚ ਕਰ।ੋ 

4. ਸੇਵ ਕਰੋ ਅਤ ੇਪ©ੇ ਕਰੋ: File → Save ਤੇ ਕਿਲੱਕ ਕਰ,ੋ ਿਫਰ Slide Show ਟਬੈ ਤ� ਿਰਹਰਸਲ ਜ� ਪ©ੇ ਕਰ।ੋ 

ਇਹ ਕਦਮ ਤੁਹਾਨੰੂ ਿਕਸ ੇਵੀ ਦਰ©ਕ ਲਈ ਪ�ਭਾਵ©ਾਲੀ ਅਤ ੇਪ©ੇਾਵਰ ਪ�ਜ਼�ਟੇ©ਨ ਬਣਾਉਣ ਿਵੱਚ ਮਦਦ ਕਰਦੇ ਹਨ। 
 
Q. How you can include animaƟon, transiƟons and graphics in your slides? Give suitable examples. (Nov 
19) 
Ans. MicrosoŌ PowerPoint offers tools to enhance presentaƟons using animaƟons, transiƟons, and 
graphics, making slides more dynamic and engaging. 
1. Adding AnimaƟons: 
AnimaƟons allow objects (text, images, shapes) to appear, move, or change during a slide show. 
Steps: 

 Select the object (e.g., a text box or image). 
 Go to the AnimaƟons tab. 
 Choose an effect like Fade, Fly In, or Zoom. 
 Use the AnimaƟon Pane to control Ɵming, order, and duraƟon. 

Example: Make bullet points appear one by one using the “Appear” animaƟon. 
 

2. Adding TransiƟons: 
TransiƟons control how one slide changes to the next. 
Steps: 

 Click on the slide you want to apply a transiƟon to. 
 Go to the TransiƟons tab. 
 Select effects like Push, Wipe, or Morph. 
 Set DuraƟon and choose Apply To All if needed. 
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Example: Use a “Fade” transiƟon between slides for a smooth visual flow. 
 

3. InserƟng Graphics: 
Graphics enhance the visual appeal and clarity of content. 
Steps: 

 Go to Insert → Pictures, Shapes, or SmartArt. 
 Choose a file or graphic style. 
 Resize and posiƟon the graphic. 

Example: Insert a pie chart to represent sales data visually. 
These features make presentaƟons more professional and interacƟve. 
ਮਾਇਕਰੋਸੌਫਟ ਪਾਵਰਪਇੰੌਟ (MicrosoŌ PowerPoint) ਪ�ਜ਼�ਟ©ੇਨ ਨੰੂ ਹੋਰ ਆਕਰ©ਕ ਬਣਾਉਣ ਲਈ ਐਨੀਮ©ੇਨ, ਟ��ਜ਼ੀ©ਨ 

ਅਤ ੇਗ�ਾਿਫਕਸ ਵਰਗੇ ਟਲੂ ਮੁਹੱਈਆ ਕਰਦਾ ਹ।ੈ ਇਹਨ� ਫੀਚਰ� ਨਾਲ ਸਲਾਈਡ� ਹੋਰ ਿਦਲਚਸਪ ਅਤ ੇਪ�ਭਾਵ©ਾਲੀ ਬਣਦੀਆ ਂ

ਹਨ। 

 
1. ਐਨੀਮੇ©ਨ ਜੋੜਨਾ (Adding AnimaƟons): 

ਐਨੀਮ©ੇਨ ਨਾਲ ਟੈਕਸਟ, ਿਚੱਤਰ ਜ� ©ੇਪ ਨੰੂ ਪ�ਸਤੁਤੀ ਦੌਰਾਨ ਿਹਲਾਉਣ, ਿਦਖਾਉਣ ਜ� ਬਦਲਣ ਦੀ ਸਮਰਥਾ ਿਮਲਦੀ ਹ।ੈ 
ਕਦਮ: 

 ਉਸ ਆਬਜੈਕਟ ਨੰੂ ਚਣੁ ੋ(ਉਦਾਹਰਨ: ਟੈਕਸਟ ਬਾਕਸ ਜ� ਇਮੇਜ)। 

 AnimaƟons ਟਬੈ 'ਤੇ ਜਾਓ। 

 Fade, Fly In, ਜ� Zoom ਵਰਗਾ ਪ�ਭਾਵ ਚਣੁ।ੋ 

 AnimaƟon Pane ਦੀ ਵਰਤ� ਕਰਕ ੇਸਮ�, ਕ�ਮ ਅਤ ੇਅਵਧੀ ਿਨਰਧਾਰਤ ਕਰ।ੋ 

ਉਦਾਹਰਨ: "Appear" ਐਨੀਮ©ੇਨ ਨਾਲ ਬਲੇੁਟ ਪਵਾਈਟਂਸ ਨੰੂ ਇੱਕ-ਇੱਕ ਕਰਕ ੇਿਦਖਾਓ। 

 
2. ਟ��ਜ਼ੀ©ਨ ਲਗਾਉਣਾ (Adding TransiƟons): 

ਟ��ਜ਼ੀ©ਨ ਨਾਲ ਇੱਕ ਸਲਾਈਡ ਤ� ਦੂਜੀ ਵੱਲ ਜਾਣ ਦਾ ਢੰਗ ਿਨਰਧਾਰਤ ਕੀਤਾ ਜ�ਦਾ ਹ।ੈ 
ਕਦਮ: 

 ਉਸ ਸਲਾਈਡ 'ਤ ੇਕਿਲੱਕ ਕਰ ੋਿਜਸ 'ਤੇ ਟ��ਜ਼ੀ©ਨ ਲਗਾਉਣਾ ਹ।ੈ 

 TransiƟons ਟਬੈ 'ਤੇ ਜਾਓ। 

 Push, Wipe ਜ� Morph ਵਰਗਾ ਅਸਰ ਚਣੁ।ੋ 

 DuraƟon ਸਟੈ ਕਰ ੋਅਤ ੇApply To All ਚੁਣ ੋਜੇਕਰ ਸਭ 'ਤੇ ਲਗਾਉਣਾ ਹੋਵੇ। 

ਉਦਾਹਰਨ: "Fade" ਟ��ਜ਼ੀ©ਨ ਨਾਲ ਸਲਾਈਡ� ਦਰਿਮਆਨ ਨਰਮ ਬਦਲਾਅ ਬਣਾਓ। 

 
3. ਗ�ਾਿਫਕਸ ©ਾਮਲ ਕਰਨਾ (InserƟng Graphics): 

ਗ�ਾਿਫਕਸ ਨਾਲ ਸਲਾਈਡ ਦੀ ਿਦੱਖ ਸੋਹਣੀ ਅਤ ੇਸਮੱਗਰੀ ਹੋਰ ਵਾਧ ੂਤਰੀਕ ੇਨਾਲ ਦਰਸਾਈ ਜ�ਦੀ ਹ।ੈ 
ਕਦਮ: 

 Insert → Pictures, Shapes, ਜ� SmartArt 'ਤ ੇਜਾਓ। 

 ਇੱਕ ਿਚੱਤਰ ਜ� ਗ�ਾਿਫਕ ਚਣੁ।ੋ 

 ਗ�ਾਿਫਕ ਨੰੂ ਰੀਸਾਈਜ਼ ਤੇ ਪੋਜ਼ੀ©ਨ ਕਰ।ੋ 

ਉਦਾਹਰਨ: ਿਵਕਰੀ ਡੇਟਾ ਦਰਸਾਉਣ ਲਈ ਪਾਈ ਚਾਰਟ ©ਾਮਲ ਕਰ।ੋ 

 



GIMT COLLEGE BUDHLADA | INTRODUCTION TO INTERNET & MS-OFFICE 23 

 

ਿਨ©ਕਰ© (Conclusion): ਐਨੀਮ©ੇਨ, ਟ��ਜ਼ੀ©ਨ ਅਤ ੇਗ�ਾਿਫਕਸ ਵਰਤਣ ਨਾਲ ਪ�ਜ਼�ਟੇ©ਨ ਹੋਰ ਵੀ ਿਵਜ਼ੂਅਲੀ ਅਤ ੇਪ�ੋਫ©ੈਨਲ 

ਬਣਦਾ ਹ,ੈ ਜੋ ਦਰ©ਕ� ਨੰੂ ਪ�ਭਾਿਵਤ ਕਰਦਾ ਹ।ੈ 
 
Q. Write the funcƟoning of MS-Power Point. How the data is exported and imported in MS-Power Point? 
(Nov 24) 
Ans. MicrosoŌ PowerPoint is a presentaƟon soŌware used to create and display slideshows containing 
text, images, charts, audio, video, and animaƟons. Its main funcƟon is to help users present ideas clearly 
and visually during meeƟngs, lectures, or events. 
FuncƟoning of MS PowerPoint: 

 PowerPoint presentaƟons are made up of slides, each used to convey specific informaƟon. 
 Users can insert text, graphics, charts, and mulƟmedia into slides using the Insert tab. 
 Designs and themes can be applied to maintain consistency and enhance visual appeal. 
 AnimaƟons and transiƟons are used to add moƟon to objects or slides, improving engagement. 
 Slide Show mode allows for presenƟng the slides one at a Ɵme, with or without narraƟon or 

Ɵmings. 
ImporƟng Data: 

 From Excel or Word: Use Insert → Object to embed or link charts and tables from Excel or text 
from Word. 

 From other presentaƟons: Use Insert → Reuse Slides to import slides from another PowerPoint 
file. 

 Media files: Insert images, audio, or video from your device or the internet. 
ExporƟng Data: 

 Use File → Export to save the presentaƟon as a PDF, video, PowerPoint Show (.ppsx), or images. 
 You can also save slides as JPEG/PNG for use in other documents or websites. 

PowerPoint’s import/export features make it flexible and compaƟble with other tools. 
 ਮਾਇਕਰੋਸੌਫਟ ਪਾਵਰਪੌਇੰਟ (MicrosoŌ PowerPoint) ਇੱਕ ਪ�ਸਤੁਤੀ (presentaƟon) ਸਫੌਟਵੇਅਰ ਹ ੈਜੋ ਸਲਾਈਡ ©ੋਜ਼ 

ਬਣਾਉਣ ਅਤ ੇਦਰਸਾਉਣ ਲਈ ਵਰਿਤਆ ਜ�ਦਾ ਹ।ੈ ਇਹ ਿਵੱਚ ਟਕੈਸਟ, ਿਚੱਤਰ, ਚਾਰਟ, ਆਡੀਓ, ਵੀਡੀਓ ਅਤ ੇਐਨੀਮ©ੇਨ 

©ਾਮਲ ਕੀਤੇ ਜਾ ਸਕਦ ੇਹਨ। ਇਸਦਾ ਮੁੱ ਖ ਉਦ©ੇ ਿਵਚਾਰ� ਨੰੂ ਦਰ©ਕ� ਨੰੂ ਸਾਫ਼, ਿਦੱਖੀਅਤ ਅਤ ੇਪ�ਭਾਵ©ਾਲੀ ਢੰਗ ਨਾਲ ਪ©ੇ 

ਕਰਨਾ ਹ।ੈ 

 
MS PowerPoint ਦੀ ਕਾਰਗੁਜ਼ਾਰੀ (FuncƟoning of MS PowerPoint): 

 ਪ�ਜ਼�ਟੇ©ਨ ਸਲਾਈਡ� ਤ� ਬਣੀ ਹੁੰ ਦੀ ਹ,ੈ ਹਰ ਸਲਾਈਡ ਿਵਚ ਵੱਖ-ਵੱਖ ਜਾਣਕਾਰੀ ਿਦੱਤੀ ਜ�ਦੀ ਹ।ੈ 

 Insert ਟਬੈ ਦੀ ਵਰਤ� ਕਰਕ ੇਟੈਕਸਟ, ਗ�ਾਿਫਕਸ, ਚਾਰਟ ਅਤ ੇਮੀਡੀਆ ©ਾਮਲ ਕੀਤ ੇਜ�ਦੇ ਹਨ। 

 Designs ਅਤ ੇThemes ਨਾਲ ਪਰੇੂ ਪ�ਜ਼�ਟੇ©ਨ ਿਵੱਚ ਇਕਸਾਰਤਾ ਤ ੇਸੁੰ ਦਰਤਾ ਆ�ਦੀ ਹ।ੈ 

 AnimaƟons ਅਤ ੇTransiƟons ਨਾਲ ਸਲਾਈਡ� ਨੰੂ ਿਹਲਦਾ-ਚਲਦਾ ਅਤ ੇਿਦਲਚਸਪ ਬਣਾਇਆ ਜ�ਦਾ ਹ।ੈ 

 Slide Show ਮਡੋ ਿਵੱਚ ਇੱਕ-ਇੱਕ ਕਰਕ ੇਸਲਾਈਡ� ਦਰਸਾਈ ਜ�ਦੀਆ ਂਹਨ, ਆਵਾਜ਼ ਜ� ਸਮ� ਿਨਰਧਾਰਨ ਸਮੇਤ। 

 
ਡਾਟਾ ਇੰਪੋਰਟ ਕਰਨਾ (ImporƟng Data): 

 Excel ਜ� Word ਤ�: Insert → Object ਦੀ ਵਰਤ� ਕਰਕ ੇExcel ਦੀਆ ਂਟਬੇਲ� ਜ� Word ਤ� ਟੈਕਸਟ ਜੋਿੜਆ ਜ�ਦਾ 

ਹ।ੈ 

 ਹੋਰ PowerPoint ਫਾਈਲ ਤ�: Insert → Reuse Slides ਦੀ ਵਰਤ� ਕਰਕ ੇਿਕਸ ੇਹੋਰ PowerPoint ਪ�ਜ਼�ਟੇ©ਨ ਤ� 

ਸਲਾਈਡ� ਜੋੜ ਸਕਦੇ ਹ।ੋ 
 ਮੀਡੀਆ ਫਾਈਲ� ਤ�: Insert → Pictures / Audio / Video ਨਾਲ ਿਚੱਤਰ, ਆਡੀਓ ਜ� ਵੀਡੀਓ ©ਾਮਲ ਕਰ ਸਕਦ ੇ

ਹ।ੋ 
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ਡਾਟਾ ਐਕਸਪੋਰਟ ਕਰਨਾ (ExporƟng Data): 

 File → Export ਦੀ ਵਰਤ� ਕਰਕ ੇਪ�ਜ਼�ਟੇ©ਨ ਨੰੂ PDF, Video, PowerPoint Show (.ppsx), ਜ� ਿਚੱਤਰ� (images) 

ਿਵੱਚ ਸੇਵ ਕੀਤਾ ਜਾ ਸਕਦਾ ਹ।ੈ 

 ਸਲਾਈਡ� ਨੰੂ JPEG ਜ� PNG ਿਚੱਤਰ� ਵਜ� ਸੇਵ ਕਰਕ ੇਹੋਰ ਦਸਤਾਵੇਜ਼ ਜ� ਵੈ{ਬਸਾਈਟ� 'ਤੇ ਵਰਿਤਆ ਜਾ ਸਕਦਾ ਹ।ੈ 

 
ਿਨ©ਕਰ© (Conclusion): PowerPoint ਦੀ ਇੰਪੋਰਟ/ਐਕਸਪਰੋਟ ਿਵ©ੇ©ਤਾਵ� ਇਸਨੂੰ  ਹੋਰ ਟਲੂ� ਨਾਲ ਲਚਕੀਲਾ ਅਤ ੇ

ਅਨੁਕੂਲ ਬਣਾ�ਦੀਆ ਂਹਨ, ਿਜਸ ਨਾਲ ਇਹ ਿਸੱਿਖਆ, ਵਪਾਰ ਅਤ ੇਿਵਿਗਆਨਕ ਖੇਤਰ� ਿਵੱਚ ਬਹੁਤ ਹੀ ਲਾਭਕਾਰੀ ਸਾਬਤ ਹੁੰ ਦਾ 

ਹ।ੈ 

 


